LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-16-2002, 11:35 AM   #1
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Rep: Reputation: 30
Unhappy No sound in Slackware 8


Ive just made a fresh install of Slackware 8 and most things seemes right .. but i have no sound ? how do i fix this ?
 
Old 02-16-2002, 01:27 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Can you get sound as root? If it's just users that can't hear sound, it's because of the file permissions of the audio devices in /dev. The "proper" way to set it up is adding a group called audio or sound etc.. and adding users to that group. Here is what you may want to try. First find out what the last gid(group id) is in /etc/group by doing this; cat group
Note the last number. Now do the following:
groupadd -g 102 (make this number the one AFTER the one you noted in the group file) audio <---Or whatever you want to call the group.
You'll want to add a user to that group. If you want joe to be in that group then you could modify his userstatus by doing this;
usermod -G audio joe <---Adds joe to audio
then cd /dev and change the ownership of the audio files to audio by doing this;
chown -v root.audio audio audio1 dsp dsp1 sequencer sequencer2
then change the permissions of said files like this;
chmod -v 464 audio audio1 dsp dsp1 sequencer sequencer2
That's it, now joe can hear sound properly. The 464 is debateable. That sets the permissions to r--rw-r-- thereby only users in the group will hear sound, you can mess with those. If I made any goofs yuh'all, please correct me.
 
Old 02-16-2002, 02:42 PM   #3
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Original Poster
Rep: Reputation: 30
Unhappy Didnt work

I did all things exactly as you explained .. but it didnt work .. when i logout from X i see " couldnt open /dev/dsp no such device" or something ...

I have a SB PCI 128 ..

:smash:

.. and something else: the "users Home icon" & Trash can doesnt show on the desktop - untill i start nautilus !? it pops up ! ( Running Gnome )

Last edited by Fuel; 02-16-2002 at 02:53 PM.
 
Old 02-16-2002, 05:42 PM   #4
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Well, I should've thought about it sooner, but you are going to want to load the appropriate sound module in the /etc/rc.d/rc.modules file. I'm not in Slack at the moment but if you edit that file, scroll down to sound support and you should see the soundblaster support. Just uncomment the module by taking away the hash '#' reboot and then first see if root has sound. After that we can worry about getting the users sound if there is any problem.
 
Old 02-17-2002, 02:16 AM   #5
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Original Poster
Rep: Reputation: 30
getting closer

as i told you before .. i have a SB 128 PCI .. but the module es1370 doesnt work - es1371 does.

..nothing happend when i rebooted, so .. in a terminal window i run the command " esd " but first i had to get su ( sudo /bin/bash ) .. then my speakers beeped and scared the shit out of me :-)

ive changed the preferences in XMMS from the default driver OSS something to eSound something and now i can play MP3s

But do i have to du this everytime i start Slack / X ? run the command " esd " ? and when i tried to open the audio mixer app - it asks me if i have permissins to open /dev/mixer


rights here and there .. :-(
 
Old 02-17-2002, 10:00 AM   #6
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
perhaps this will help...

i'm running slack8 on my thinkpad, and before i installed the 2.4.17 kernel on my system, i had to use alsa modules for my soundcard, so to load them at boot time i added the following lines to my /etc/rc.d/rc.local file:

# start sound card (old; now compiled into kernel 2.4.17)
###modprobe char-major-116
###modprobe char-major-14
###modprobe snd-card-0
###modprobe sound-slot-0
###modprobe sound-service-0-0
###modprobe sound-service-0-1
###modprobe sound-service-0-3
###modprobe sound-service-0-12

so you'll wanna look into what modules you should be loading at boot time, simply loading your card's module won't be enough, since there are modules for your mixer, pcm, oss, synth, and other things.

hope this helps. :-)
 
Old 02-20-2002, 09:26 AM   #7
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Original Poster
Rep: Reputation: 30
what the heck is this ?

i did not put those lines in the rc-local file but it loks like root has sound everytime i reboot .. what about my user .. it seemes like many has problems with sound in slackware ..
 
Old 02-20-2002, 09:36 AM   #8
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
yeah, in slackware only root has permissions to access your soundcard. you'll either wanna create a new group for your sound devices or change the permissions on the hardware itself. refer to this post for some more info:

http://www.linuxquestions.org/questi...threadid=11190
 
Old 02-20-2002, 11:40 AM   #9
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Original Poster
Rep: Reputation: 30
well .. some kind of solution ..

My steps during this mess ..

Act 1:

vi /etc/rc.d/rc.modules # uncommented my sound module es1371

groupadd -g 102 sound
usermod -G sound root
usermod -G sound fuel

chown -v root.sound audio audio1 dsp dsp1 sequencer sequencer2 mixer mixer1
chmod -v 464 audio audio1 dsp dsp1 sequencer sequencer2 mixer mixer1

Pause: :smash:

Act2:

/opt/gnome/bin/gmix ... 0777 ... File group: users
/dev/mixer & mixer1 ... 0777

and woila ! my sound works

comments to this ?

Last edited by Fuel; 02-21-2002 at 04:32 AM.
 
Old 02-04-2004, 05:25 PM   #10
olarteo
LQ Newbie
 
Registered: Jan 2004
Posts: 8

Rep: Reputation: 0
Try

/sbin modprobe trident

if works add this line to file etc/rc.d/rc.modules
bye
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound in Slackware 10 Prism Slackware 21 09-07-2004 02:48 AM
no sound in slackware 9.1 johntramp Linux - Software 14 04-12-2004 11:44 AM
Replaced a Sound Card (ESS) and now no sound under Slackware LeniuNYC Linux - Hardware 1 03-14-2004 05:21 PM
Sound in Slackware 9.1?? patrik1982 Slackware 4 10-19-2003 07:19 PM
AC97 int. sound slackware 9.0 no sound TheDanLayerOSI Linux - Hardware 1 06-13-2003 04:42 AM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration