LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-29-2013, 12:36 PM   #1
manofllama
LQ Newbie
 
Registered: Jan 2013
Posts: 5

Rep: Reputation: Disabled
No sound in Debian 7 on EEEPC 1201n kernel 3.1


I am running debian 7.0 with linux kernel 3.1.0-1-486. I have alsa installed and pulseaudio. I run FVWM-crystal as my window manager. I get no sound in any application or from the system. Alsamixer is turned up, but nothing makes noise. Anybody know what I can do to fix or troubleshoot this?
 
Old 01-29-2013, 12:39 PM   #2
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,921

Rep: Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050
Welcome to the forums! Why not give the currently supported Debian 3.2 kernel a try, maybe it has better support for your sound card?
 
Old 01-29-2013, 04:30 PM   #3
manofllama
LQ Newbie
 
Registered: Jan 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
I've upgraded to kernel 3.2. Still no sound. Alsa mixer just says "(default)" or "enter device name" under "Select sound card."
 
Old 01-29-2013, 05:53 PM   #4
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,921

Rep: Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050Reputation: 1050
I did a quick Google search and it appears your EEE is significantly different hardware-wise than my 900ha. I think maybe yours has Nvidia graphics and audio; does that sound accurate? You can confirm this with the terminal command:

Code:
lspci
I am not an expert on Nvidia but I know Debian does not include these "non free" drivers by default. Hopefully one of our resident Nvidia-in-Debian experts will be along shortly to assist. You can read about Nvidia on the Debian wiki (but proceed with caution; perhaps better to wait for some guided assistance than to forge ahead):

http://wiki.debian.org/NvidiaGraphicsDrivers

Apologies if my Nvidia guess is inaccurate.
 
Old 01-29-2013, 07:13 PM   #5
manofllama
LQ Newbie
 
Registered: Jan 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
lspci does seem to indicate that it is a "00:08.0 Audio Device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)"
 
Old 01-29-2013, 08:30 PM   #6
manofllama
LQ Newbie
 
Registered: Jan 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
So I did a full update, upgrade and dist-upgrade. Now I've realized that if I have an application running that should have sound, it still doesn't. However if I leave that app running (in FVWM on tty7) and go to another TTY (1-6 seem to work) I can hear the audio! It stops as soon as I go back to tty7 and will resume when I go to any other TTY. Any clues?
 
Old 02-04-2013, 02:21 PM   #7
manofllama
LQ Newbie
 
Registered: Jan 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
I solved the issue. All drivers were fine. I just needed to add my user to the audio group.

Code:
sudo useradd <username> audio

Last edited by manofllama; 02-11-2013 at 04:16 PM. Reason: I didn't wanna multi-post again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian eeePC Not Detecting Wireless Networks Bradj47 Linux - Laptop and Netbook 12 05-31-2011 08:48 PM
Debian Wheezy hangs on EeePC Changes Linux - General 10 04-20-2011 10:10 AM
Installing Debian Squeeze on a 1201n 108134865 Debian 18 08-11-2010 06:59 PM
debian on Asus EEEPC cccc Debian 6 10-26-2008 02:04 PM
LXer: 9-inch EeePC named EeePC 900 and gets detailed specs LXer Syndicated Linux News 1 03-11-2008 08:11 AM


All times are GMT -5. The time now is 01:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration