LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-10-2010, 04:01 PM   #1
kwikness
Member
 
Registered: Apr 2006
Location: MA
Distribution: Slackware 13
Posts: 67

Rep: Reputation: 15
No Sound From Flash Player (Slackware)


Hi, I have a fairly fresh install of Slackware and I just installed the flash plugin for Firefox. After installing the flash plugin, I'm able to view videos, but I'm unable to hear any sound.

- Pidgin also does not play sound
- Amarok plays sound fine
- Other KDE system event sounds play fine (i.e. starting and leaving X)
- I used alsaconf to configure my sound as it wasn't working right after the Slackware install

Does anyone know where I can start in resolving this issue?
 
Old 10-10-2010, 04:52 PM   #2
dudeman41465
Member
 
Registered: Jun 2005
Location: Kentucky
Distribution: Ubuntu
Posts: 794

Rep: Reputation: 56
Install OSS sound system, I believe Pidgin uses it as does Flash player. The package "alsa-oss"(I'm in Ubuntu) should do the trick for you, it's an Alsa wrapper for OSS applications.

Last edited by dudeman41465; 10-11-2010 at 04:09 AM.
 
Old 10-10-2010, 04:55 PM   #3
kwikness
Member
 
Registered: Apr 2006
Location: MA
Distribution: Slackware 13
Posts: 67

Original Poster
Rep: Reputation: 15
Thanks, but how do I do that under Slackware?
 
Old 10-10-2010, 07:10 PM   #4
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,525

Rep: Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704
Try reading this post to see if it helps:

http://www.linuxquestions.org/questi...193/page2.html
 
Old 10-10-2010, 07:53 PM   #5
kwikness
Member
 
Registered: Apr 2006
Location: MA
Distribution: Slackware 13
Posts: 67

Original Poster
Rep: Reputation: 15
Tried:
Code:
usermod -a -G audio,video,cdrom,plugdev,power,netdev your_username
and logging out as suggested by the post but no dice.

Any other suggestions? Please!!
 
Old 10-10-2010, 09:30 PM   #6
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,411

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Slackbuild for OSS. Read the Slackbuild HOWTO.

But there might be something else going on. I have not encountered any problems using flashplayer in Slack in five years of Slacking.

Last edited by frankbell; 10-10-2010 at 09:33 PM.
 
Old 10-27-2010, 07:58 PM   #7
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Rep: Reputation: 2
I am having the same problem, I have built the OSS slackbuild but I was wondering, is it possible to use both OSS and Alsa at the same time? Alsa works fine for everything but Firefox.

And just to clear this up, please tell me if this is a true statement: "Adobe Flash player supports OSS but not Alsa."
 
Old 06-04-2012, 05:23 PM   #8
Faker
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
N00b1 reporting in

just installed slackware, flash and oss and still no sound, help. also flashplayer doesn't work in anything else apart from youtube on opera no other flash video site works, why is this and how do i fix it.

Last edited by Faker; 06-04-2012 at 05:40 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound from flash player rob.rice Linux - General 1 06-29-2008 11:46 PM
No Real Player Sound after Flash Player hroit Linux - Software 4 01-16-2007 02:05 PM
Flash player sound problems sw67 Slackware 3 03-16-2005 05:34 AM
Flash player sound sync is off!!!! mykrob Linux - Software 6 02-04-2005 05:33 PM


All times are GMT -5. The time now is 06:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration