LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   No Sound From Flash Player (Slackware) (http://www.linuxquestions.org/questions/linux-software-2/no-sound-from-flash-player-slackware-837263/)

kwikness 10-10-2010 05:01 PM

No Sound From Flash Player (Slackware)
 
Hi, I have a fairly fresh install of Slackware and I just installed the flash plugin for Firefox. After installing the flash plugin, I'm able to view videos, but I'm unable to hear any sound.

- Pidgin also does not play sound
- Amarok plays sound fine
- Other KDE system event sounds play fine (i.e. starting and leaving X)
- I used alsaconf to configure my sound as it wasn't working right after the Slackware install

Does anyone know where I can start in resolving this issue?

dudeman41465 10-10-2010 05:52 PM

Install OSS sound system, I believe Pidgin uses it as does Flash player. The package "alsa-oss"(I'm in Ubuntu) should do the trick for you, it's an Alsa wrapper for OSS applications.

kwikness 10-10-2010 05:55 PM

Thanks, but how do I do that under Slackware?

yancek 10-10-2010 08:10 PM

Try reading this post to see if it helps:

http://www.linuxquestions.org/questi...193/page2.html

kwikness 10-10-2010 08:53 PM

Tried:
Code:

usermod -a -G audio,video,cdrom,plugdev,power,netdev your_username
and logging out as suggested by the post but no dice.

Any other suggestions? Please!!

frankbell 10-10-2010 10:30 PM

Slackbuild for OSS. Read the Slackbuild HOWTO.

But there might be something else going on. I have not encountered any problems using flashplayer in Slack in five years of Slacking.

harksaw 10-27-2010 08:58 PM

I am having the same problem, I have built the OSS slackbuild but I was wondering, is it possible to use both OSS and Alsa at the same time? Alsa works fine for everything but Firefox.

And just to clear this up, please tell me if this is a true statement: "Adobe Flash player supports OSS but not Alsa."

Faker 06-04-2012 06:23 PM

N00b1 reporting in
 
just installed slackware, flash and oss and still no sound, help. also flashplayer doesn't work in anything else apart from youtube on opera no other flash video site works, why is this and how do i fix it.


All times are GMT -5. The time now is 02:32 AM.