LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-08-2003, 12:51 PM   #1
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
no smbmount command


i haven't seen this problem anywhere: after installing samba and using it for the past few weeks, i find i don't have the smbmount/smbmnt command.

until now i've only been using samba to access files on my linux box from my laptop, but this weekend i took my second hard drive out of my linux machine and put it into a new one, and now i can't access the files on it (win2k). i'm going to put linux on there anyway, but right now i need to get those files. is there a compile option i might have missed, either in the kernel or when compiling samba? i can't think of what else it might be.

 
Old 12-08-2003, 01:12 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
maybe you just haven't install the samba client utils. you don't say what distro this is on, not redhat I assume, but most RPM based distros have a server, client and common samba packaegs. but if you can use "mount -t smbfs /whatever" then you're home and dry anyway and don't need smbmount
 
Old 12-08-2003, 01:20 PM   #3
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Original Poster
Rep: Reputation: 47
it's slackware, thanks. didn't know the utils was a separate package not included in samba -- i even searched freshmeat for smbmount and smbmnt before posting and didn't find anything -- any idea where i can get that? the mount command just keeps spitting the help screen back at me. i guess i'll mess around with it a little more -- appreciate.

--------------------
>update

as i suspected, i neglected to add a compile option when installing samba:

When attempting to mount, the following error is generated:

[root:spatula:/]$mount -t smbfs -o username=linuxsamba //venti/music /mp3
mount: wrong fs type, bad option, bad superblock on //venti/music,
or too many mounted file systems

make sure /sbin/mount.smbfs -> /usr/local/bin/smbmount
(this means you need smbmount installed. did you forget to --with-smbmount?)

http://www.diversedev.com/misc/linux_notes/samba

in case anyone else is having similar problems...

Last edited by synaptical; 12-09-2003 at 01:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
smbmount Red Squirrel Linux - Networking 1 08-24-2005 06:28 AM
I have no smbmount! Vincent_Vega Linux - Networking 4 03-15-2004 01:22 PM
smbmount? mbtoys Linux - Networking 0 08-29-2003 09:10 AM
smbmount etc GrayLOK Linux - Networking 5 07-21-2002 03:37 AM
smbmount ??? vwhk Linux - General 2 01-23-2002 09:54 AM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration