LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   "No Java virtual machine could be found from your PATH" - ignores bashrc (http://www.linuxquestions.org/questions/linux-software-2/no-java-virtual-machine-could-be-found-from-your-path-ignores-bashrc-219309/)

shaider 08-18-2004 01:36 PM

"No Java virtual machine could be found from your PATH" - ignores bashrc
 
I'm tryig to install LimeWire in Fedora and this message appears. Now, I installed java and added the path into the .bashrc (both root and regular user's), and nothing worked. here's my bashrc config:

export PATH=/usr/java/j2re1.4.2_05/bin:$PATH
export JAVA_HOME="/usr/java/j2re1.4.2_05"


can anyone identify any problem with this path command?

320mb 08-18-2004 01:50 PM

export JAVADIR=/usr/java/j2re1.4.2_05

try this one...........

shaider 08-18-2004 02:11 PM

dude... it worked! thanks a million!

Jimbo99 09-07-2004 09:54 PM

Thanks, this worked for me too. I had the same problem and I was pretty miffed by it.

I have had problems with java all round. I can't believe how bad it is. My main problem is that I can't get www.ionthunder.com to work. I take down and install the java runtimes but the program still complains that it can't find the appropriate java stuff.

If you have any ideas on it I'd appreciate it.

Caffeinate 10-07-2004 12:40 PM

Alright, total newbie here, already successfully installed the Java SDK (I couldn't get the Vm lone package to work) but I don't even know where to begin with editting the bash file with the appropriate PATH commands. If someone could give me (or direct me to) the appropriate directions, would be appriciated.

IBall 10-08-2004 02:44 AM

Simply open the file ~/.bashrc and add the lines

Code:

PATH=/path/to/java/bin:$PATH
JAVA_HOME=/path/to/java
export PATH
export JAVA_HOME

save the file, and run the command:
Code:

source ~/.bashrc
Now try executing the command "java", and it should give a help message.

I hope this helps
--Ian

Caffeinate 10-08-2004 10:45 AM

Perfect, thank you much.

Now, I've had some problems with an editted .bash file when I was setting up WinE. I added the appropriate "PATH" lines to .bash_profile and the programs ran perfectly. However, once I reset the computer, WinE wouldn't run any more, giving the error:

Code:

wine: could not exec /home/<username>/wine-20040914/wine-pthread
Would this need to be in .bash_rc instead, as well, and/or do I have to source this each time I restart and/or is there someway to get all this to happen at startup??

IBall 10-09-2004 01:38 AM

Sorry but I don't know about wine.

You don't need to manually source .bashrc or .bash_profile each time you log in, as this is done automatically.

--Ian


All times are GMT -5. The time now is 10:21 PM.