LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-18-2013, 01:45 PM   #1
alexiph
LQ Newbie
 
Registered: May 2013
Posts: 2

Rep: Reputation: Disabled
No audio with Nvidia 610 GT over HDMI


Hi, all. Have been reading several forum posts here on LQ regarding issues with audio over HDMI, though haven't found any answers to my problem.

I bought a Nvidia 610 GT in hope to be able to play video and audio through HDMI on my recently installed Ubuntu Server 13.04 (without desktop environment). I've had no problems playing either audio or video before installing the Graphics card. But I'm not able to play any audio.

In alsamixer I can only find two settings (previously there were more); S/PDIF and S/PDIF 1.
alsamixer

I'm not sure whether this is a problem or not. Anyhow, I have checked so that no channels are muted.

lspci:
Code:
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
aplay -L:
Code:
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 1
    HDMI Audio Output
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 1
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 1
    Direct sample snooping device
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 1
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 1
    Hardware device with all software conversions
speaker-test -Dhdmi:NVidia -c2
Code:
speaker-test 1.0.25

Uppspelningsenhet är hdmi:NVidia
Strömparametrar är 48000 Hz, S16_LE, 2 kanaler
Använder 16-oktavers rosa brus
Frekvensen inställd till 48000 Hz (begärde 48000 Hz)
Buffertstorleken varierar från 64 till 16384
Periodstorleken varierar från 32 till 8192
Använder maximal buffertstorlek 16384
Perioder = 4
tidigare inställd period_size = 4096
tidigare inställd buffer_size = 16384
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,639972
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,971973
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,971974
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,975984
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,971989
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,975976
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,971977
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,971985
 0 - Vänster fram
 1 - Höger fram
Tid per period = 5,975987
 0 - Vänster fram
 1 - Höger fram
(sry about the language, but I think you get the picture)

However, I don't get any sound when I run speakertest.
Any suggestions?

Last edited by alexiph; 05-18-2013 at 01:55 PM.
 
Old 05-20-2013, 06:51 AM   #2
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
Try this

create asoundrc file in your home directory
Code:
touch .asoundrc
put it in .asoundrc
Code:
pcm.!default {
      type hw
      card 0
      device 3
 }
 
Old 05-20-2013, 07:52 AM   #3
alexiph
LQ Newbie
 
Registered: May 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Adding the .asoundrc dind't change anything the number of channels in alsamixer remain 2 s/pdif.
I removed .asoundrc again and apt-get remove nvidia*

And magically it works.

Thank you for taking the time.

Last edited by alexiph; 05-20-2013 at 09:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa config for c310 usb webcam and nvidia GeForce 210 hdmi audio micemicerabies Linux - Software 1 03-31-2013 12:13 AM
nVidia HDMI Audio sherb114 Linux - Hardware 8 04-06-2012 06:42 AM
HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) felipefv Linux - Hardware 8 02-06-2012 09:47 AM
[SOLVED] unable to set up kernel drivers and modules for HDA Nvidia (audio via hdmi) gjwalsh Linux - Hardware 5 06-18-2011 06:57 PM
nVidia HDMI Audio Doesn't Work scott12087 Linux - Hardware 19 03-09-2011 04:43 PM


All times are GMT -5. The time now is 04:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration