LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   no audio with CD player? (http://www.linuxquestions.org/questions/linux-software-2/no-audio-with-cd-player-147719/)

LinuxCrusader 02-18-2004 04:04 PM

no audio with CD player?
 
I'm currently running Fedora core 1. When I insert a music cd into the cd-rom drive, CD player starts playing the cd and it even recognizes the name of the songs, but I can't hear any audio. Both of my dvd-rom(RW) and cd-rom are working. Is there a plug in that I'm missing of something?

Xmms also won't play audio cds. When I hit the play button, it brings a window where I can search for files...so I navigate to /dv/cdrom and it won't bring up any of the songs in the cd.

Anybody knows how to fix this problem? Thanks in advance..

carlywarly 02-18-2004 04:27 PM

You need an audio cable from the back of the CDROM drive to your soundcard. Then check the mixer settings, too.

LinuxCrusader 02-18-2004 04:40 PM

Audio cable?

If these cd-roms are working properly under XP, you still think I need audio cable? I just bought this computer like a month ago...so I've never opened it. I don't think the problem is audio cable because I remember when I was trying Mandrake that I can play CDs with Totem, plus currently I can watch dvds with full audio....

J.W. 02-18-2004 07:02 PM

Well you didn't make any mention of the fact that things were working properly under XP in your original post, just that it didn't work in Linux. As carlywarly indicated, if you can eliminate the soundcard's cable as the source of the problem, then it may be that your audio settings have been muted, or that the volume is turned all the way down. You will want check the mixer settings to confirm that the volumes are set high enough to be heard.

As for XMMS, have you tried using /mnt/cdrom as the target directory? That might do the trick. Lastly, note that XMMS has its own volume setting, so you'll want to confirm that it's set high too (the volume setting is the smaller slider bar on top of the progress bar as the song plays.) -- J.W.

LinuxCrusader 02-18-2004 09:04 PM

Quote:

then it may be that your audio settings have been muted, or that the volume is turned all the way down. You will want check the mixer settings to confirm that the volumes are set high enough to be heard.

As for XMMS, have you tried using /mnt/cdrom as the target directory? That might do the trick. Lastly, note that XMMS has its own volume setting, so you'll want to confirm that it's set high too (the volume setting is the smaller slider bar on top of the progress bar as the song plays.) -- J.W.
I tried doing in XMMS using /mnt/cdrom as a target directory and I can see all the tracks in the cd, but then when I start playing them, there still no sound. Volume settings are find because I can play mp3s with it. I tried going options-->preferences->Audio I/O plugins (first tab) and there's "cd audio player 1.28 (libcdaudio.so)" plug in, which then I hit the configure button and then it brings another window where there's a section for playmode and audio control, I tried selecting cdrom drive and it still no audio.

As for the cd player...I issue the command $aumix to check the mixer settins and still no sound...Please help!

LinuxCrusader 02-18-2004 09:10 PM

hey guys, I got XMMS working now. it was in analog play mode. So I selected "Digital audio extraction" (duh!) and CD-rom drive when configuring the cd audio player. I hope this helps somebody else.

But for the cd player...anybody else anymore recomendatons?


All times are GMT -5. The time now is 10:01 PM.