LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   No Alert sound Thunderbird 3.1.1 0x80004005 (NS_ERROR_FAILURE) - KDE 3.5, Hardy (http://www.linuxquestions.org/questions/linux-software-2/no-alert-sound-thunderbird-3-1-1-0x80004005-ns_error_failure-kde-3-5-hardy-821725/)

cricksen 07-23-2010 11:32 AM

No Alert sound Thunderbird 3.1.1 0x80004005 (NS_ERROR_FAILURE) - KDE 3.5, Hardy
 
Hello,
After upgrading from TBird 3.0.x to 3.1.1 I lost new email alert sounds. The system plays sounds .wav fine. Running ALSA. The TBird eror console says:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISound.play]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/preferences/general.js :: anonymous :: line 94" data: no]

THANKS FOR HELPING ME

mlangdn 07-24-2010 01:28 AM

It seems that TB requires esound. I installed esound on my Slackware64-current box, and still no sound. I'm gonna keep lookin' 'cause this is bugging the heck out of me. Either that, or I'm going back to 3.0.

mlangdn 07-24-2010 02:19 AM

I tried to use esound for another notification and it said that esound did not work and was going back to the default. It seems that TB may need to go to something alse. Esound seems to be way outdated.

cricksen 07-24-2010 09:22 AM

I tried esound.....did not fix it.

hammack 07-26-2010 10:37 AM

I'm having the same problem with Thunderbird 3.1.1 under Slackware 13.0 and xfce4. Google finds lots of references to the same error message with earlier versions of Thunderbird (https://bugzilla.mozilla.org/show_bug.cgi?id=378155) and the solution *seems* to be esound.

But this bug is at least three years old. Does it make sense that three years after this bug was reported 3.0.x works okay without esound but 3.1.1 does not? I'm confused, but will try esound as described in the bug report and see what happens.

hammack 07-26-2010 11:12 AM

(Slack 13.0 SUCCESS!) No Alert sound Thunderbird 3.1.1 0x80004005 (NS_ERROR_FAILURE)
 
I installed esound 0.2.41 on my Slack 13.0 machine and started the esd daemon (as myself - not as root!) and it works.

It did work when root started the daemon, however.

mlangdn 08-02-2010 03:26 PM

How do you start the esound daemon? I can't seem to get that right.

cricksen 08-02-2010 06:35 PM

I am using ALSA sound system. I also have esound installed but still no TB sound. I am not sure is esound is entirely necessary because I can play any .wav sound outside of TB.

hammack 08-03-2010 08:44 AM

I'm using the xfce desktop and started it from Settings->Session and Startup->Application Autostart. I don't know what the equivalent is for kde.

You could start it instead by editing your .bashrc and adding the line: /usr/bin/esd &

hammack 08-03-2010 08:46 AM

cricksen, I'm using alsa also and can play any sound outside of thunderbird without esound. But I can only get sounds from thunderbird by starting the esound daemon (/usr/bin/esd). Just having esound installed is not enough by itself - the daemon must be running.

mlangdn 08-03-2010 09:01 AM

It didn't work in .bashrc. I started it using krunner (Alt+F2). It works now!
Think I'll put it in rc.local.

cricksen 08-03-2010 10:02 AM

Mlangdn, Hammmack.....IT WORKED: JUST RAN ALT + F2 THEN TYPED ESD AND it WORKS....WILL ADD ESD TO AUTOSTRAT UNDER KDE

I WOULD LIKE TO THANK ALL OF YOU FOR YOUR HELP!

MANY THANKS

cricksen 08-03-2010 11:09 AM

Correction: to autostart the esound daemon edit /etc/esound/esd.conf and change auto_spawn=0 to auto_spawn=1
It says autospwning is not recomended; it's ambiguous?? But worked for me. If done in ~/.kde/Autostart/esd.desktop it will play a sound during login.

Real question is why does TBird app require esound when existing ALSA sound system plays all .wav files?


All times are GMT -5. The time now is 08:27 PM.