LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   NFS share in fstab fails to mount, but where is the log? (http://www.linuxquestions.org/questions/linux-software-2/nfs-share-in-fstab-fails-to-mount-but-where-is-the-log-744166/)

gumpish 07-31-2009 10:02 AM

NFS share in fstab fails to mount, but where is the log?
 
Hello.

I have two RHEL 5 systems, one has an NFS export and the other has that share listed in its fstab file. The client system should be trying to mount the NFS share upon bootup, correct?

It seems the last time the client system was restarted the NFS share didn't mount - however I don't see anything in /var/log/messages about it. I was able to mount the share manually.

I'm not as concerned at the moment about the fact that the share didn't mount automatically as much as I am concerned about the fact that I can't seem to find any log entries about the failure. Where should such failures appear? Or are they not logged by default??

Thanks!

catkin 07-31-2009 10:18 AM

Hello gumpish :)

There might be something in the /var/log boot log file.

Best

Charles

gumpish 08-01-2009 10:26 PM

Nope, the /var/log/boot file for the time period in question is empty...

jlinkels 08-02-2009 11:40 AM

Since I assume the server was running at the time of the reconnection attempt, you should check /var/log/messages in the server. Those messages provide more information than the client's.

Most of the times when an NFS share doesn't mount (which usuall does) is because of a network issue. For example because the reverse DNS wasn't working (yet).

jlinkels

catkin 08-02-2009 12:05 PM

Hello gumpish :)

I write from an ubuntian perspective so you may need to translate into RedHatish.

Check that network, portmap and nfs-common init scripts are called before mountall.sh; if they are not, the only thing that makes NFS mounts in /etc/fstab work at all is that NFS keeps trying long enough for the network to come up later.

One possible cause of the network coming up slowly is switches which may queue certain types of packets (I say "certain" because I'm not certain which!). I've seen similar threads in which the solution has been to re-configure Cisco switches.

There may be timeouts available on the NFS options in /etc/fstab which you could extend.

Another solution may be to remove the NFS entries from /etc/fstab and to program their mounting into a later init script like rc.local.

Best

Charles

catkin 08-02-2009 12:08 PM

Another thought; you may be able to solve/improve the situation by using IP addresses rather than names when specifying the NFS mounts in the fstab or, if you really want names, using the hosts file rather than a DNS server for name resolution. This way you are not dependent on network facilities to get the IP address of the NFS server.

rainzone 08-19-2009 03:45 PM

look in /var/logs/secure?
 
You might want to look in /var/logs/secure. RHEL 5 writes a bunch of messages there which I would have otherwise looked for in /var/logs/messages. I think that's because it's 'security enabled' SELinux.

chrism01 08-19-2009 07:22 PM

You could try the automount solution post #7 http://www.linuxquestions.org/questi...-mount-746785/

The relevant RH manual section http://www.linuxtopia.org/online_boo...ig-autofs.html


All times are GMT -5. The time now is 02:18 AM.