LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 02-03-2004, 11:36 AM   #1
sanfran49
Member
 
Registered: Jun 2003
Location: Oklahoma
Distribution: Debian, Windows 2K,
Posts: 41

Rep: Reputation: 15
Newly installed Slackware 9.1 error message


Hello,

I'm new to slackware, have only worked with Debian. I downloaded and installed Slackware 9.1 cd's on my laptop which happens to be a Dell Smartstep 200n Pentium 4. When I try to check the network settings with the ifconfig command or search for files with the locate comand I recieve the following error message:

modprobe: modprobe : Can't open dependencies file /lib/ modules/2.4.19/modules.dep (No such file or directory)

When I go to the /lib/modules/ directory I see the following :

2.4.22/

The problem appears to be that it is looking for a /2.4.19 kernel directory . I installed the sytem with the 2.4.22 kernel. Which obviously is there :


I do not know what to do. Can anyone help.

Thanks in Advance,

Tony
 
Old 03-10-2004, 05:22 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
there have been a number of upgrades so you may want to download the new kernel, its header and its modules and then run

upgradepkg (file) from your download directory in su mode

someone should be able to tell you a good mirror for US.
 
Old 03-10-2004, 07:06 AM   #3
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
do a :

depmod -a

i think that cured it for me

You may also have to manually create the folder it's asking for to allow it to place the file's it needs there. Do that before the depmod -a

Ade

Last edited by Evilone; 03-10-2004 at 07:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just installed XFCE - question on error message... eagle63 Linux - Newbie 3 09-01-2005 04:34 PM
installed Router, error message dareino Fedora 4 04-20-2005 10:42 PM
Slackware error message after Installation atko Slackware - Installation 6 06-09-2004 03:14 PM
Hardware problems with newly installed Slackware 9.1.. Elite_Gamer04 Linux - Hardware 1 05-21-2004 07:03 AM
Newly installed slackware system will not boot yelo Slackware - Installation 5 05-11-2004 06:01 AM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration