LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-26-2004, 07:12 AM   #1
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Rep: Reputation: 15
New to Linux geforce2 questions


Hi all!

Just installed Linux Redhat 9.0 for the first time, very cool OS. But i have problems changing the resolution on my gforce2 400 mx. I downloaded the latest nvidia drivers and changed the config file to use "nvidia". But my X just keeps jumping back to 800x600. I guess this is the most common question in the linux universe but how do i fix it? i just dont want to giv up on linux becouse of something as simple as this!

Cheers! //Tom
 
Old 03-26-2004, 07:38 AM   #2
nirvanix
Member
 
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
Look at the file /etc/X11/XF86Config. There should be a 'Screens section' which has a subsection as show below:

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubsection

This section sets the available and initial (here 1024x768) screen resolutions for the different color depths (8,16,24,32). Maybe yours has 800x600 in front? Change it (as root) and restart the X windows.
 
Old 03-26-2004, 07:49 AM   #3
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
OK Here is my config file, please tell me what to edit:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 03-26-2004, 10:09 AM   #4
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
anyone?
 
Old 03-26-2004, 05:01 PM   #5
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
I know my monitor type now i found a windows driver here: http://www.gericom.com/german/produc...s/business.htm
Its a 15" Gericom DH-1564, i havent found a linux driver, could some expert please help me with this, ive been struggling for hours!!
 
Old 03-26-2004, 05:32 PM   #6
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Change this to read.......

Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" 
EndSubSection
EndSection
 
Old 03-26-2004, 06:22 PM   #7
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
I changed the settings to above. Now i just get a blue screen when booting up witch i can choose yes or no, its only possible to choose no and when i do that x doesnt load.
 
Old 03-26-2004, 06:58 PM   #8
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Could someone please help me im so stuck.....
 
Old 03-26-2004, 07:47 PM   #9
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
?
 
Old 03-26-2004, 08:29 PM   #10
HarPaX
LQ Newbie
 
Registered: Oct 2003
Posts: 29

Rep: Reputation: 15
Double check to make sure you have made the chages as per 320mb's post. If you are still having problems you might try to ensure that the HSync and Vertrefresh values are correct for your monitor. Also, try to install the driver provided by Nvidia for X. Make sure you read the documentation that comes with Nvidia's driver, as this will also require some changes to your XF86Config file.

Be careful when changing monitor frequency settings, it is conceiveable that you could damage the monitor if you set something out of range.
 
Old 03-26-2004, 08:56 PM   #11
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you for the support HarPax, i got the monitor driver for windows, here is what is says:

; TRLMON.INF Pixie Monitor information
; Copyright 1996 Royal Information Company

[version]
signature="$CHICAGO"
Class=Monitor
Provider=%TRL%
CatalogFile=trlmon.cat


[ClassInstall32]
AddReg=ClassAddReg32

[ClassAddReg32]
HKR,,,,%MonitorClassName%
HKR,,Icon,,"-1"
HKR,,NoInstallClass,,1

[DestinationDirs]
DefaultDestDir=11
TRL-DH1764.CopyFiles=23
TRL-X555.CopyFiles=23
TRL-DH1564.CopyFiles=23
TRL-DH1764U.CopyFiles=23

[SourceDisksNames]
1="TRL/RIC Monitor Installation Disk.",,1
73170=WHQL,"",73170

[SourceDisksFiles]
DH1764.ICM=1
X555.ICM=1
DH1564.ICM=1
DH1764U.ICM=1
trlmon.cat=73170

[Manufacturer]
%TRL%=TRL

[TRL]
%TRL-RH1564%=TRL-DL1564, Monitor\TRL061C
%TRL-DH1764%=TRL-DH1764,Monitor\TRL0510
%TRL-DH1570%=TRL-DH1570,Monitor\TRL0410
%TRL-DL1750MU%=TRL-DL1750MU,Monitor\TRL0310
%TRL-DH1764U%=TRL-DH1764U,Monitor\TRL0610
%TRL-DH1764%=TRL-DH1764.Install,Monitor\TRL0510
%TRL-X555%=TRL-X555.Install,Monitor\TRL1010
%TRL-DH1564%=TRL-DH1564.Install,Monitor\TRL1009
%TRL-DH1764U%=TRL-DH1764U.Install,Monitor\TRL0610

;Install Section

[TRL-DL1564]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DL1564.AddReg, 1280, DPMS


[TRL-DH1764]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1764.AddReg, 1280, DPMS


[TRL-DH1570]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1570.AddReg, 1280, DPMS


[TRL-DL1750MU]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DL1750MU.AddReg, 1280, DPMS


[TRL-DH1764U]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1764U.AddReg, 1600, DPMS

[TRL-DH1764.Install]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1764.AddReg, 1280, DPMS
CopyFiles=TRL-DH1764.CopyFiles

[TRL-X555.Install]
DelReg=DEL_CURRENT_REG
AddReg=TRL-X555.AddReg, 1024, DPMS
CopyFiles=TRL-X555.CopyFiles

[TRL-DH1564.Install]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1564.AddReg, 1024, DPMS
CopyFiles=TRL-DH1564.CopyFiles

[TRL-DH1764U.Install]
DelReg=DEL_CURRENT_REG
AddReg=TRL-DH1764U.AddReg, 1280, DPMS
CopyFiles=TRL-DH1764U.CopyFiles



; Common AddReg/DelReg sections
;-------------------------------------------------
[DEL_CURRENT_REG]
HKR,MODES
HKR,,MaxResolution
HKR,,DPMS
HKR,,ICMProfile

[640]
HKR,,MaxResolution,,"640,480"
[800]
HKR,,MaxResolution,,"800,600"
[1024]
HKR,,MaxResolution,,"1024,768"
[1280]
HKR,,MaxResolution,,"1280,1024"
[1600]
HKR,,MaxResolution,,"1600,1200"

[DPMS]
HKR,,DPMS,,1

;AddReg Sections

[TRL-DL1564.AddReg]
HKR,"MODES\1280,1024",Mode1,,"29.0-64.0,47.0-100.0,+,+"
HKR,,ICMProfile,1,7

[TRL-DH1764.AddReg]
HKR,"MODES\1280,1024",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,1,7

[TRL-DH1570.AddReg]
HKR,"MODES\1280,1024",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,1,7

[TRL-DL1750MU.AddReg]
HKR,"MODES\1280,1024",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,1,7

[TRL-DH1764U.AddReg]
HKR,"MODES\1600,1200",Mode1,,"29.0-85.0,47.0-120.0,+,+"
HKR,,ICMProfile,1,7

[TRL-DH1764.AddReg]
HKR,"MODES\1280,1024",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,0,"DH1764.ICM"

[TRL-X555.AddReg]
HKR,"MODES\1024,768",Mode1,,"29.0-55.0,50.0-120.0,+,+"
HKR,,ICMProfile,0,"X555.ICM"

[TRL-DH1564.AddReg]
HKR,"MODES\1024,768",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,0,"DH1564.ICM"

[TRL-DH1764U.AddReg]
HKR,"MODES\1280,1024",Mode1,,"30.0-82.0,47.0-120.0,+,+"
HKR,,ICMProfile,0,"DH1764U.ICM"



[TRL-DH1764.CopyFiles]
DH1764.ICM

[TRL-X555.CopyFiles]
X555.ICM

[TRL-DH1564.CopyFiles]
DH1564.ICM

[TRL-DH1764U.CopyFiles]
DH1764U.ICM



[Strings]
MS="Microsoft"

TRL="Royal Information Company"
TRL-RH1564="TRL/RIC DL-1564"
TRL-DH1764="TRL/RIC DH-1764M/DH-1764"
TRL-DH1570="TRL/RIC DH-1570M/DH-1570"
TRL-DL1750MU="TRL/RIC DL-1750MU"
TRL-DH1764U="TRL/RIC DH-1764UM/DH-1764U"
TRL-DH1764="TRL/RIC DH1764"
TRL-X555="TRL/RIC X555"
TRL-DH1564="TRL/RIC DH1564"
TRL-DH1764U="TRL/RIC DH-1764U"

--------------------


My model is DH-1564, i think setting the Hsync and Vertrefresh rate is the solution but im unsure where in the above file its mentioned, you seem more familiar with this maybe you could figure it out?
 
Old 03-26-2004, 09:14 PM   #12
HarPaX
LQ Newbie
 
Registered: Oct 2003
Posts: 29

Rep: Reputation: 15
This line contains the refresh rates for that resolution

[TRL-DH1564.AddReg]
HKR,"MODES\1024,768",Mode1,,"29.0-70.0,47.0-120.0,+,+"
HKR,,ICMProfile,0,"DH1564.ICM"

I SUSPECT that the 29.0-70.0 is the HSync and the 47.0-120.0 is the Vertrefresh but I can't be 100% sure. Try at your own risk.
 
Old 03-28-2004, 05:56 PM   #13
Sence2001
LQ Newbie
 
Registered: Mar 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you HarPax, problem is now solved! you ar an angel!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux: Activating TV-Out on Asus/GeForce2 card asciimonster Linux - Hardware 3 06-10-2007 08:04 PM
geforce2 redduck666 Linux - Hardware 1 03-14-2005 05:19 AM
anybody ever have problems with geforce2? breadbin Linux - Hardware 2 08-27-2003 05:00 PM
Geforce2 ti on Xconfig??? thom Slackware 2 08-24-2002 07:08 PM
Abit geforce2 MX Stimm Linux - General 2 11-19-2000 12:35 PM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration