LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-15-2003, 10:49 AM   #1
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Rep: Reputation: 15
Unhappy New GAIM problem


I want to update my Gaim to 0.72. I've downloaded "gaim-0.72-1rh9.i386.rpm" and "gtkspell-2.0.4.tar.gz" and now when I go "rpm -ivh gaim-0.72-1rh9.i386.rpm" says:

Warning /*/*/gaim-0.72-1rh9.i386.rpm: V3 DSA signature: NOKEY, key ID 88c1c14
error: Failed dependencies:
libtk8.3.so is needed by gaim-0.72-1rh9

I've downloaded "tk-8.3.5-88 RPM for i386" but when I go "rpm -ivh (file)" says something like exclusive lock or something? What I do?
 
Old 11-15-2003, 11:14 AM   #2
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Try putting both RPMs in the same dir and do this:
rpm -ivh *.rpm
and it should solvee dependencies and intstall in the proper order.
 
Old 11-15-2003, 11:49 AM   #3
Pougan
Member
 
Registered: Nov 2003
Location: Pouganis -- a planet not too far from over there.
Distribution: Vector
Posts: 31

Rep: Reputation: 15
Downloading the tar.gz and installing it that way worked for me .
 
Old 11-15-2003, 12:06 PM   #4
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
yea i had similar problems but i fixed it by compiling from the source tar.gz aswell
 
Old 11-15-2003, 01:42 PM   #5
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
Quote:
says something like exclusive lock or something
that sounds like your not in root
 
Old 11-15-2003, 08:34 PM   #6
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Original Poster
Rep: Reputation: 15
Can someone tell me step by step please, Rember I already have the files:

"gaim-0.72-1rh9.i386.rpm"
"gtkspell-2.0.4.tar.gz"
"tk-8.3.5-88 RPM for i386"
 
Old 11-15-2003, 10:07 PM   #7
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
From a prompt:

su -c "rpm -ivh tk-8.3.5-88 RPM for i386"
(Are you sure that is the name of the rpm? I think it is really tk-8.3.5-88.i386.rpm so the command should be su -c "rpm -ivh tk-8.3.5-88.i386.rpm")

tar -xvzf gtkspell-2.0.4.tar.gz
cd gtkspell-2.0.4
./configure
make
su -c "make install"

cd ../
su -c "rpm -ivh gaim-0.72-1rh9.i386.rpm"

That SHOULD do it...
 
Old 11-16-2003, 03:28 AM   #8
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Original Poster
Rep: Reputation: 15
Thanks but to make it easier for me:

I've just reformatted and just install red hat 9, finished downloading the updates and I want to update Gaim. Can you please provide links and a step by step guide (like above but with links)
 
Old 11-16-2003, 10:42 AM   #9
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Quote:
Can someone tell me step by step please, Rember I already have the files:

"gaim-0.72-1rh9.i386.rpm"
"gtkspell-2.0.4.tar.gz"
"tk-8.3.5-88 RPM for i386"
If you already have these files, like you said you did, the step by step instructions above should work fine. If you reinstalled and lost those files, you will have to download them again. I would go to RPMfind.net and get all the required files as rpm's. I went ahead and sent you the links for the three files I know you need:

You should get gtkspell-2.0.4-fr3.i386.rpm, gaim-0.72-2.fr.i386.rpm and tk-8.3.5-88.i386.rpm.

Save them all in the same folder. Then from a command prompt:

cd /where/you/saved/files/ <--i.e. /home/syst3m_snip3r/downloads/ or /temp/files/
su -c "rpm -ivh *.rpm"
You will be prompted for root password.

Rpm will solve the dependencies and install the rpm files in the right order. If there is a dependency file you need, it will tell you and you can go back to RPMfind.net and download the required file(s), save it with the rest and run the su -c "rpm -ivh *.rpm" command again.
 
Old 11-20-2003, 03:57 AM   #10
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Original Poster
Rep: Reputation: 15
Ok thanks BUT what do i type in "rpm -ivh *.rpm"?
 
Old 11-20-2003, 12:30 PM   #11
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Someone way before this should have mentioned you should be typing rpm -Uvh *.rpm...

us U when installing because it installs by upgrading current files instead of just mindlessly replacing files with its own and asking you 50,000 if you wanna overwrite things.
 
Old 11-22-2003, 10:47 PM   #12
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Original Poster
Rep: Reputation: 15
I did above and this happens:

[*@localhost *] cd /home/*/Downloads
[*@localhost Downloads]$ su -c "rpm -ivh *.rpm"
Password:
warning: gaim-0.72-2.fr.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
Preparing... ########################################### [100%]
package tk-8.3.5-88 is already installed
file /usr/bin/gaim from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/autorecon.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/iconaway.so from install of gaim-0.72-2.fr conflicts
with file from package gaim-0.59.8-0
file /usr/lib/gaim/libgg.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/libirc.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/libjabber.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/libmsn.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/libnapster.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/libyahoo.so from install of gaim-0.72-2.fr conflicts
with file from package gaim-0.59.8-0
file /usr/lib/gaim/libzephyr.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/notify.so from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0
file /usr/lib/gaim/spellchk.so from install of gaim-0.72-2.fr conflicts
with file from package gaim-0.59.8-0
file /usr/share/man/man1/gaim.1.gz from install of gaim-0.72-2.fr conflicts with file from package gaim-0.59.8-0

What I done wrong now?
 
Old 11-22-2003, 10:54 PM   #13
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
as stated in my last post.. use. "U" vh, instead of i
 
Old 11-22-2003, 10:55 PM   #14
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
you have to uninstall gaim first by "rpm -e gaim" if that does works do "rpm -e --nodeps gaim" which wasn't very good.
But if you install gaim right after that, i think there should be a problem.
 
Old 11-23-2003, 03:01 AM   #15
Syst3m_Snip3r
Member
 
Registered: Nov 2003
Posts: 40

Original Poster
Rep: Reputation: 15
Ok thanks got it all working now . BUT is there an add-on or something so that when I log into MSN its says if I have new e-mails like in MSN for windows?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem using GAIM Junior24 Linux - Newbie 2 12-29-2004 01:50 PM
GAIM problem thegamegraal Linux - Software 4 12-09-2004 12:53 PM
problem with gaim chaitu_iiit Linux - Software 1 12-08-2004 12:34 PM
little problem with gaim citrus Linux - Software 8 01-25-2004 03:43 PM
Problem Installing/Upgrading Gaim 0.60 or Gaim 0.71 AskMe Linux - Newbie 1 10-25-2003 09:00 PM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration