LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   network/soundcard driver issue (http://www.linuxquestions.org/questions/linux-software-2/network-soundcard-driver-issue-498651/)

pellle87 11-04-2006 04:20 PM

network/soundcard driver issue
 
ive got some issues with my drivers on my cpu, the network card is marvell technology group ltd. 88e8001 gigabit ethernet controller (rev 13) and ive searched google for answers but i didnt find any solution... someone told me to try: modprobe sk98lin but when i tryed it i got the error message: FATAL: could not load /lib/modules/2.6.18/modules.dep: no such file or directory and now i was wondering if someone of you could help me, im running slack 11.0

aus9 11-05-2006 09:03 AM

firstly I do not know if that is the correct driver but it can be made a module or compiled into your kernel.

take a look with a text editor (as a normal user NOT root) at
/boot/config...or config-your-kernel-version

scroll down to this section
# Ethernet (1000 Mbit)
#
# CONFIG_ACENIC is not set
# CONFIG_DL2K is not set
# CONFIG_E1000 is not set
# CONFIG_NS83820 is not set
# CONFIG_HAMACHI is not set
# CONFIG_YELLOWFIN is not set
CONFIG_R8169=y
# CONFIG_R8169_NAPI is not set
# CONFIG_SIS190 is not set
# CONFIG_SKGE is not set
# CONFIG_SKY2 is not set
# CONFIG_SK98LIN is not set

the last line shows I have compiled my kernel not to have such a driver in the kernel and not in /lib/modules/your -kernel

2) so if it was
CONFIG_SK98LIN=m

then you can run as root the command
modprobe sk98lin and then lsmod to check its running and then try to use your hardware

if it works then add the modprobe commmand to your /etc/rc.local script

3) if it was =y then it is already loaded and you just have to tweak your system otherwise its set to no and you need to compile the same kernel but reset the switch to y or m

compiling kernels for your distro should be roughly the same as most distro as slack stays almost vanilla.

check out slacks dox to see how that is done if needed

Andrew Benton 11-05-2006 10:20 AM

Quote:

Originally Posted by pellle87
FATAL: could not load /lib/modules/2.6.18/modules.dep: no such file or directory

Try running (as root) depmod


All times are GMT -5. The time now is 08:59 PM.