LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-24-2003, 01:48 AM   #1
shellcode
Member
 
Registered: May 2003
Location: Beverly Hills
Distribution: Slackware, Gentoo
Posts: 350

Rep: Reputation: 31
nemesis libraries problem


hi. im trying to install nemesis on my new system. nemesis need libnet-1.0.2a but i also want libnet-1.1.0 installed (better and not depreceated).

ok so for libnet-1.0.2a I installed as follows:
./configure --prefix=/usr/lib/libnet-1.0.2a
make
su
make install
exit

no problem

for libnet-1.1.0 I installed as followes:
./configure --prefix=/usr/lib/libnet-1.1.0
make
su
make install
exit

no problem

i add:
/usr/lib/libnet-1.0.2a
/usr/lib/libnet-1.1.0

to /etc/ld.so.conf

i make /etc/profile.d/libnet-1.0.2a.sh and put in:
#!/bin/bash
PATH=${PATH}:/usr/lib/libnet-1.0.2a/bin
to add the path to the binary

i run ldconfig as root.

now i try to install the latest nemesis:
./configure --with-libnet-libraries=/usr/lib/libnet-1.0.2a --with-libnet-includes=/usr/libnet-1.0.2a

checking for libnet.h... no

ERROR! Libnet header not found, go get it from
http://www.packetfactory.net/projects/libnet/
or use the --with-libnet-* options, if you have it installed
in unusual place


no go.

./configure --with-libnet-libraries=/usr/lib/libnet-1.0.2a/lib --with-libnet-includes=/usr/libnet-1.0.2a/include

checking for libnet.h... no

ERROR! Libnet header not found, go get it from
http://www.packetfactory.net/projects/libnet/
or use the --with-libnet-* options, if you have it installed
in unusual place

no go again.

./configure ...no go.

any ideas, i really want both 1.0.2a and 1.1.0 installed. thank you.
 
Old 09-25-2003, 01:43 AM   #2
shellcode
Member
 
Registered: May 2003
Location: Beverly Hills
Distribution: Slackware, Gentoo
Posts: 350

Original Poster
Rep: Reputation: 31
i tried hacking the makefile and whatnot but with no result.

isnt my method of installing the two libnets the correct way to install two libraries that would normally conflict and overwrite each other?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem loading libraries lolipop Linux - Software 2 04-23-2005 01:25 PM
Problem accessing libraries DDD26 Linux - Newbie 4 12-16-2004 05:38 PM
my compiler problem is in the libraries dogbird Linux - Software 1 11-25-2004 06:01 PM
Problem With Libraries. flamesrock Linux - Software 4 10-13-2003 09:43 PM
Attention All Geeks: Star Trek Nemesis Rocks! MasterC General 34 01-12-2003 08:40 PM


All times are GMT -5. The time now is 03:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration