LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-16-2009, 03:07 AM   #1
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Rep: Reputation: 2
Need help with joomla used on localhost


i installed apache2 php5 mysql and all that, after that i got the joomla done all the configuration and stuff and i was able to start my joomla control panel by going to http://localhost/administrator/index.php and it takes me to the control panel of the joomla and i can manage the website and make changes to it but i am not able to open the website to see it when i go to http://localhost it says "It Works !" and as i recall this was showing up when i was setting up the apache to show me that its working and now i don't know how to access and see the website that im making changes to with joomla

Can someone help me find or somehow redirect the http://localhost to point at the website that im building with the joomla so that im able to see what im changing

Please help
 
Old 07-16-2009, 03:16 AM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
What's in your .htaccess file?
 
Old 07-16-2009, 03:34 AM   #3
di11rod
Member
 
Registered: Jan 2004
Location: Austin, TEXAS
Distribution: CentOS 6.5
Posts: 207

Rep: Reputation: 32
Sycamorex is a skilled troubleshooter, but I think I have the answer.

Go into your web directory (likely /var/www)

and rename the file index.html to OLD_index.html

Joomla has likely put some other file in there called "index" but with a different extension. Apache will pick up the 'index.html' file first and send that out to anyone who requests the root of the web server.

After you rename the index.html to OLD_index.html, the page request (http://localhost) should get handled by your Joomla install.

Best wishes,

di11rod
 
Old 07-16-2009, 01:41 PM   #4
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
i already installed the joomla and i can go to the conrol panel but i can't see the website itself, anyways im gonna try what u suggested after i go back home from work

and about the .htaccess file i did no modifications to it its the default one which goes with the joomla

im gonna paste the htaccess file later when i have access to that computer if its really necessary

Last edited by Bodi; 07-16-2009 at 01:43 PM.
 
Old 07-16-2009, 01:50 PM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
Also, make sure that you've got the following in httpd.conf
Code:
<IfModule dir_module>
    DirectoryIndex index.php index.html index.htm
</IfModule>
AFAIK, joomla uses index.php
 
Old 07-16-2009, 02:12 PM   #6
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
ok ill check that too when i go back home, anyways any suggestion where the joomla is storing the created website, in which file exactly
 
Old 07-16-2009, 02:16 PM   #7
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
The main page would be index.php but most elements will be scattered around directories as modules.
 
Old 07-16-2009, 02:19 PM   #8
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
ok thanks everybody ill try all that when i have access to the PC and if i dont make it work will post here, anyways if u have any other suggestions which might help feel free to share them
 
Old 07-16-2009, 02:28 PM   #9
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
Another possibility:
You might want to check if php is enabled in apache's httpd.conf
To enable it uncomment the following line:
Quote:
# Include /etc/httpd/mod_php.conf
 
Old 07-16-2009, 02:40 PM   #10
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
i think i dont have httpd in there i think it was /etc/apache2/apache2.conf i used this "howto" to set up the apache the mysql and the php https://help.ubuntu.com/community/ApacheMySQLPHP all from this tutorial worked except the phpmyadmin , which is not relevant to this problem
 
Old 07-16-2009, 02:54 PM   #11
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
Quote:
Originally Posted by Bodi View Post
i think i dont have httpd in there i think it was /etc/apache2/apache2.conf i used this...
Yeah, it doesn't matter - /etc/httpd is slackware's. Where did you install joomla? What's the path to joomla directory on your computer? You might want to rename joomla's htaccess.txt to .htaccess

Also I come accross a post where someone said that on localhost and windows hosts joomla needs specifying the main file at the end of the address eg. index.php. I haven't checked it, though.
 
Old 07-16-2009, 02:55 PM   #12
di11rod
Member
 
Registered: Jan 2004
Location: Austin, TEXAS
Distribution: CentOS 6.5
Posts: 207

Rep: Reputation: 32
Quote:
Originally Posted by sycamorex View Post
Another possibility:
You might want to check if php is enabled in apache's httpd.conf
To enable it uncomment the following line:

php is enabled, because he is able to access the administration pages, which are dynamic php.

The problem here is what sycamorex hinted at earlier. The .htaccess has index.html ordered before index.php. This can also be easily fixed by just deleting (renaming) the default index.html file that is placed in the docroot during a fresh apache install.

If you want to check .htaccess, just make sure that index.php is before index.html

di11rod
 
Old 07-16-2009, 03:06 PM   #13
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,533
Blog Entries: 1

Rep: Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999Reputation: 999
Quote:
php is enabled, because he is able to access the administration pages, which are dynamic php.
Oops, silly me.
 
Old 07-16-2009, 03:11 PM   #14
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by sycamorex View Post
Where did you install joomla? What's the path to joomla directory on your computer?
the path is /var/www/ and also i have the same files in /home/user/public_html due to another tutorial that i went through and i kept them both but i suppose its using the /var/www/ path
 
Old 07-16-2009, 03:12 PM   #15
Bodi
LQ Newbie
 
Registered: Jul 2009
Posts: 25

Original Poster
Rep: Reputation: 2
yeah before i enabled the php it was asking me to download the index.php file and i guess i have activated it because its browsing it not trying to download it
 
  


Reply

Tags
joomla


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache : localhost/ works localhost/index.html does not PhilA Linux - Server 4 05-27-2007 07:32 PM
MySQL: Why are there two roots localhost, and localhost.localdomain? paulsiu Linux - Server 6 04-18-2007 09:43 AM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM


All times are GMT -5. The time now is 03:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration