LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-07-2003, 01:36 PM   #1
phaeton
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 9.0
Posts: 8

Rep: Reputation: 0
Need Help with GLIB


I am trying to get glib to work, but I have an old glib installed and I want to install this new version 2.2.2. I believe glib was installed from an RPM but I'm not sure, it just came with redhat. I tried make clean and make distclean from my glib 2.2.2 source dir but that didn't remove the old version. If anyone could help that would be great.
 
Old 07-07-2003, 01:50 PM   #2
phaeton
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 9.0
Posts: 8

Original Poster
Rep: Reputation: 0
*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

This is the error that I get when I am trying to install atk. I want to install Pango and the new glib and the new gtk so that I can use the new xchat.
 
Old 07-08-2003, 12:03 PM   #3
phaeton
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 9.0
Posts: 8

Original Poster
Rep: Reputation: 0
Can someone help please?
 
Old 07-10-2003, 12:11 PM   #4
phaeton
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 9.0
Posts: 8

Original Poster
Rep: Reputation: 0
bump... i haven't been able to solve the problem, i have installed glib 2.2.2 over 2.0.6 and im not sure how to stop the system from recognizing 2.0.6. Is it something to do with pkg-config? my pkg-config returns that 2.2.2 is installed...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration