Here is more errors that basically say the same thing I got when installing a package called "PANGO". The version of GLIB installed is GLIB-2.2.3 but I do not know how to force 'ldconfig' to update the correct links or if this is even the right way to get the system configured correctly. Hope this helps:
checking for GLIB - version >= 2.1.3...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.