LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   need help compiling from source - libtool error (http://www.linuxquestions.org/questions/linux-software-2/need-help-compiling-from-source-libtool-error-461071/)

Feeg 07-04-2006 11:16 PM

need help compiling from source - libtool error
 
Hi, I'm trying to get Papaya (a MUD client) to compile on my Slackware machine.

I've managed to get past a couple of errors, but now I'm stumped. The program says to run aclocal, automake, autoconf, then configure and make.

When I make the program the source files seem to compile fine, but when it comes time to link, I get this:

Code:

/bin/sh ../../libtool --tag=CXX --mode=link g++  -g -O2  -o papaya -lz -rdynamic -ldl  -L/usr/X11R6/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfreetype -lfontconfig -lXrender -lX11 -lXext -lpng12 -lz -lm  -L/usr/X11R6/lib -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfreetype -lfontconfig -lXrender -lX11 -lXext -lpng12 -lz -lm    papaya-About.o papaya-AliasEntity.o papaya-AutoReconnect.o papaya-BaseWindow.o papaya-Browser.o papaya-Buffer.o papaya-callbacks.o papaya-ColourEditor.o papaya-ColouredLabel.o papaya-ColourPreference.o papaya-CommandInterpreter.o papaya-CompressFilter.o papaya-CompressionPreference.o papaya-Connection.o papaya-ConnectionPreference.o papaya-copyover.o papaya-Entity.o papaya-EntityGroup.o papaya-EntityHandler.o papaya-EOLFilter.o papaya-Event.o papaya-external_app.o papaya-Fade.o papaya-FileIO.o papaya-Filter.o papaya-FilterHandler.o papaya-FontChooser.o papaya-FontPreference.o papaya-GTKTwoVT.o papaya-GTKTwoWindow.o papaya-History.o papaya-HistoryPreference.o papaya-HTTPSocket.o papaya-InputPreference.o papaya-interface.o papaya-Main.o papaya-Message.o papaya-MUDConnectorList.o papaya-MUD.o papaya-MUDSelector.o papaya-notebook.o papaya-OutputPreference.o papaya-PapayaList.o papaya-Plugin.o papaya-PluginData.o papaya-PluginHandler.o papaya-PromptFilter.o papaya-Prefs.o papaya-Preference.o papaya-PreferenceHandler.o papaya-PromptPreference.o papaya-ProxyPreference.o papaya-Socket.o papaya-Socks.o papaya-SocksFive.o papaya-Splash.o papaya-SquidSocket.o papaya-support.o papaya-SystemColour.o papaya-SystemTriggerEntity.o papaya-Telnet.o papaya-TeloptFilter.o papaya-TriggerEntity.o papaya-VT.o papaya-Win32PluginAPI.o papaya-Win32PluginAPIImplementation.o papaya-calcu.o papaya-dl.o  -lnsl
libtool: unrecognized option `--tag=CXX'
Try `libtool --help' for more information.

The libtool script that it is running contains this line:
Code:

# The names of the tagged configurations supported by this script.
available_tags=" CXX F77"

and a section within comment blocks that say:
Code:

# ### BEGIN LIBTOOL TAG CONFIG: CXX

whole lotta stuff snipped for brevity, let me know if seeing it would help..

# ### END LIBTOOL TAG CONFIG: CXX

I think I'm in way over my head here, but I'd really like to get this program to compile. Any suggestions?

Thanks.


All times are GMT -5. The time now is 04:46 PM.