LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-30-2004, 03:31 PM   #1
beaker911
LQ Newbie
 
Registered: Dec 2004
Location: portland, or
Distribution: suse 9.1
Posts: 1

Rep: Reputation: 0
Unhappy ncsd, glibc, and glibc-common conflicts during LAMP install


I'm doing a remote server installation on a Dell PowerEdge 2850 running CentOS (RH compatible). My full software task is as follows, along with what I'm using:
* Apache 1.3.33
apache_1.3.33.tar.gz
* MySQL 4.1.8
MySQL-server-4.1.8-0.i386.rpm
MySQL-bench-4.1.8-0.i386.rpm
MySQL-client-4.1.8-0.i386.rpm
MySQL-devel-4.1.8-0.i386.rpm
MySQL-shared-4.1.8-0.i386.rpm
MySQL-embedded-4.1.8-0.i386.rpm
MySQL-shared-compat-4.1.8-0.i386.rpm
* PHP 4.3.10
php-4.3.10.tar.gz
* vsFTPd 2.0.1
vsftpd-2.0.1-5.i386.rpm
* Webmin 1.170
webmin-1.170-1.noarch.rpm
* phpMyAdmin 2.6.0-pl3
phpMyAdmin-2.6.0-pl3.tar.gz
* APF
apf-current.tar.gz

I downloaded all the above, and unpacked all the tarballs. Then, I used:
rpm -Uvh *.rpm
which gave me an error of a series of failed dependencies, which I tried to meet using rpmfind.net. Here are the files I'm using to meet the dependencies:
libcap-1.10-15.1.x86_64.rpm
zlib-1.2.1.2-1.i386.rpm
libcap-1.10-8.i386.rpm
openssl-0.9.7a-40.i686.rpm
e2fsprogs-1.35-11.2.i386.rpm
krb5-libs-1.3.4-7.i386.rpm
glibc-common-2.3.3-73.i386.rpm
pam-0.77-65.i386.rpm
db4-4.2.52-6.i386.rpm
libgcc-3.4.2-6.fc3.i386.rpm
libstdc++-3.4.2-6.fc3.i386.rpm
cracklib-2.7-28.i386.rpm
glib2-2.4.7-1.i386.rpm
libselinux-1.17.14-1.i386.rpm
RPMS/tcp_wrappers-7.6-37.2.i386.rpm

* this series of rpms, when run together, eliminated the non-conflicting failed dependencies, but left me with the following error. I know I can force the install, but I'm hesitant to do that.
ERROR: Failed dependencies:
nscd < 2.3.3-52 conflicts with glibc-2.3.3-73
glibc > 2.3.2 conflicts with glibc-common-2.3.2-95.27
glibc < 2.3.3 conflicts with glibc-common-2.3.3-73

Does anyone have any ideas about how I could fix these conflicts? Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 04:22 PM
glibc-common tulip4heaven Linux - General 1 05-11-2005 07:01 AM
Glibc conflicts with Sash Kensai Mandriva 1 02-22-2004 09:32 AM
glibc common redhat 9.0 salahuddin_66 Red Hat 0 01-30-2004 02:58 AM
glibc-common dependency blues... sylk Linux - Software 4 09-19-2003 08:08 PM


All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration