LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-24-2004, 03:44 PM   #1
rosscopeeko
Member
 
Registered: Aug 2003
Location: Ipswich, UK
Distribution: mandrake 10.0
Posts: 79

Rep: Reputation: 15
nat error in azureus


hello. Have been using azureus for a while with no problems - but now i
can't connect. so i tried to install it again, but on the port test i get
a nat error - Testing port 6881 ... NAT Error.

I've tried different ports, still can't connect, tried disableing the
firewall (still no difference). all other internet are ok - as far as i
know. Anyone got a solution??

cheers,

Ross
 
Old 07-09-2004, 12:17 PM   #2
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Rep: Reputation: 30
Can anyone help us? I have the exact same problem.
 
Old 12-25-2004, 10:31 AM   #3
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Was a solution to this error ever found?
 
Old 12-25-2004, 01:09 PM   #4
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
Firewall that you referred to, is it the router firewall or the one on your computer ???.

1) Check

Azureus-->Configuration --> Server ---> Bind to local Address is "empty"
[To see if you haven't bound azureus to the ip-addr you are not currently having ie. DHCP]


2)
You can try the following to test and see if it works with a "static-ip" you currently have.

#ifconfig [to get the ip-address of your computer]
eg. 192.168.1.100

Azureus-->Configuration --> Server ---> Bind to local Address [192.168.1.100] --> Save

Restart azureus.


3) If you use DHCP

You might also want to check if the DHCP Client Table on the router reflect's the
ip-addr you have currently, or try to obtain a fresh DHCP lease.
 
Old 12-31-2004, 12:04 AM   #5
NewToLinux2005
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse Linux 9.2 Pro
Posts: 27

Rep: Reputation: 15
Hi all, I am new to Linux myself, but I think I figured this out because I was having the same problem. Rosscopeeko if you go into your firewall setting with Yast and go to additional services in Firewall Configuration: Services you can allow any port you like. Example would be if you want ports 6881 thru 7000 for TCP you would type 6881:7000. I did that and now I don't have any NAT problems.

Hope this helps.

Have a safe and happy NEW YEAR!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Testing port 6881....NAT Error - error in Azureus dr_zayus69 Linux - Security 20 05-26-2006 02:52 PM
Azureus and NAT error :( Peleus Linux - Software 1 11-08-2005 08:53 AM
Azureus NAT Error... deac0ncho Mandriva 5 10-02-2005 05:11 AM
Nat error - azureus ceborame Linux - Newbie 1 09-03-2005 11:24 AM
Azureus NAT error on port 6881 dealerman Fedora 3 08-21-2005 10:42 AM


All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration