LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-13-2006, 07:03 AM   #31
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Original Poster
Rep: Reputation: 30

Sorry brother, I never use the sound notification before. I setup this at my previous company, I didnt use Nagios now.
 
Old 06-07-2007, 03:06 AM   #32
henryJack85
LQ Newbie
 
Registered: Jun 2007
Posts: 5

Rep: Reputation: 0
Cool About the ScriptAlias and Nagios

Hey, your error solve already?

May I know where should i put this code:

ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory "/usr/local/nagios/sbin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

is read it some manual on this page (http://nagios.sourceforge.net/docs/1_0/installweb.html) said that add into the httpd.conf

Then the manual say /etc/rc.d/init.d/httpd restart.

Inside /etc/rc.d/init.d/ don't have the service call httpd.

So I yum install the httpd service.

I quite confuse here actually where is the httpd.conf file located?

I quite sure is edite the apache "httpd.conf".

Why have to restart the /etc/rc.d/init.d/httpd?

If don't have the httpd file i still can access the localhost....

I Don't know why?

Please clear it for me.

Best Regards
HenryJack
 
Old 06-19-2007, 11:50 PM   #33
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Original Poster
Rep: Reputation: 30
Is almost 1 1/2 year i didnt touch with nagios. haha..

If I am not mistaken, the below script should put in httpd.conf file
I remember there are 2 items to put in the file. There is a sequence to put it, you have to read on the documentation

ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory "/usr/local/nagios/sbin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

Regarding where is the httpd.conf file locate. Just issue find command to check it.
After edit the httpd.conf file, you may need to restart apache and test again.
 
Old 01-27-2009, 05:50 PM   #34
luis_fermoi
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
Nagios - You don't have permission to access /nagios/cgi-bin/ on this server.

Hello

How you resolve this problem? Can you help me?
Thanks...

Quote:
Originally Posted by dwarf007 View Post
Thank You for the help.....

The problem is solved, but now i encounter another problem which is.

---------------------------------------------------------------------------
Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster

Error 403

linux-nagios
Sat 27 Nov 2004 06:42:03 PM MYT
Apache/2.0.40 (Red Hat Linux)
---------------------------------------------------------------------------

Can i know whats is the problem? The folder /usr/local/nagios/sbin originally only has cgi file inside and i had change all of them to 777 permission.

Anyone knows please help........
Thank You
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios (403 Error) cuiguy Linux - Software 1 04-05-2005 06:27 PM
nagios error messages kenji1903 Linux - Networking 9 08-21-2004 05:07 AM
login problem nagios misba672 Linux - Newbie 2 10-14-2003 07:13 PM
Nagios Web Interface JPawlak Linux - Software 1 08-22-2003 03:49 PM
Nagios Web Interface sanfran49 Linux - Software 6 07-15-2003 10:36 AM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration