LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Nagios Web Interface (http://www.linuxquestions.org/questions/linux-software-2/nagios-web-interface-67742/)

sanfran49 06-24-2003 02:10 PM

Nagios Web Interface
 
I recently installed the Nagios software on my debian system. I managed to get it working to where I don't get any error messages when starting it up. However, after reading the documentation on setting up the Web Interface and doing what it said, I still cannot get the web interface to work.

Any suggestions,

Tony

mcleodnine 06-24-2003 03:14 PM

What happens when you try to access the web interface? The more information you can provide the greater the chances of your question being answered.

sanfran49 06-24-2003 04:06 PM

I just get a HTTP 404 - File not found in
Internet Explorer . My apache web server is up and running because I am running my squid web reports.

Tony

mcleodnine 06-24-2003 04:08 PM

so you put the required files in a place from which apache can server them, correct? did you create a new virtualhost for it? if so did you reload apache?

sanfran49 06-24-2003 05:05 PM

I put the following in the httpd.conf file for apache :

ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory "/usr/local/nagios/sbin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

Alias /nagios/ /usr/local/nagios/share/
<Directory "/usr/local/nagios/share">
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

I then restarted the apache web server. It still would not work.

Thanks,

tony

jharris 06-24-2003 05:47 PM

Are there any hints in your Apace error log(s)?? Exactly what URL are you requesting? http://server/nagios/ not just http://server/nagios yeah?

cheers

Jamie...

dallasnewbie 07-15-2003 11:36 AM

web interface
 
i had this problem also. apache could not read the files because they belonged to root. either change the ownership to apache or set them to nagios/nagioscmd and add nagios to the apache group.


All times are GMT -5. The time now is 09:33 AM.