LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Nagios installation (http://www.linuxquestions.org/questions/linux-software-2/nagios-installation-550659/)

SlacUser 05-02-2007 10:02 AM

Nagios installation
 
Hi, i'm trying to install NAGIOS, the network monitor software, but I can't see the graphical enviroment on the web browser, I've already done all what the documentation tells, but It keeps telling me that the requested URL cannot be found.
What could be the problem?

Thanks!!

asommer 05-02-2007 11:14 AM

Did you configure Apache for Nagios?

Here's my Apache Nagios config:

Quote:

<IfDefine NAGIOS>
ScriptAlias /nagios/cgi-bin/ /usr/nagios/sbin/
<Directory "/usr/nagios/sbin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
Alias /nagios /usr/nagios/share/
<Directory "/usr/nagios/share">
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</IfDefine>
You'll probably need something similar if you don't already have it configured. Are there any errors in your Apache logs?

SlacUser 05-02-2007 11:34 AM

Mmm?
 
Where I should put that?, httpd.conf?, because I've already modified that file with the following:

Quote:

ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"

<Directory "/usr/local/nagios/sbin">
# SSLRequireSSL
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

Alias /nagios/ "/usr/local/nagios/share"

<Directory "/usr/local/nagios/share">
# SSLRequireSSL
Options None
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

henryJack85 06-08-2007 02:01 AM

Can help you because I also face same problem....

This msg just let you happy only....

asommer 06-08-2007 07:22 AM

My next thought is what are the permissions on the directory? I have 775 for the sbin directory and everything inside it.

lowks 06-13-2007 10:50 AM

This might be a stupid question, but did you remember the trailing slash when you were trying to load the nagios site on your browser, I had the same problem and remembering that trailing slash solved it for me.


All times are GMT -5. The time now is 07:04 AM.