LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-02-2005, 08:30 PM   #1
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Mysterious key combination keeps restarting X


I'm using Enlightenment on SUSE 9.1. I've searched through my keybindings.cfg file to no avail, so I'm hoping someone here will recognize what I'm doing, so I can stop doing it
Some sort of key combination that I'm hitting restarts X. It's happened twice in the last few minutes, once while I (think) I was pressing RSHIFT and had either hit or just hit "1". The second time was shift again, and I think I was near "5" (could've been making a typo, though, so I can't swear to what I actually hit). There may or may not have been some other keys involved, I was in the middle typing code and am not sure precisely where I was :-[

/var/log/messages has this to say:
Jul 2 21:20:30 linux kdm[4573]: X server for display :0 terminated unexpectedly

which a) isn't news to me, I was using it when it "terminated"!, and b) is less than verbose. Anyone know what, other than ctrl+alt+backspace, will restart X?

Thanks!
 
Old 07-03-2005, 12:35 AM   #2
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
*sigh* nevermind. It happened again and made me lose about 5 paragraphs of an essay, at which point I started screwing around with keys 'til I figured it out.

Shift + backspace. Does it every time. Doesn't matter which shift, either.

So now the question becomes, how in blazes do I disable that? It's an absurd key combination, waaaay to easy to hit accidentally, especially when one is what could be described as a non-trained typist. It's definitely not in keybindings.cfg.
 
Old 07-04-2005, 05:10 AM   #3
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Could it be that somehow your system does not make the distinction between shift+backspace (supposed to be harmless) and ctrl+alt+backspace (supposed to restart X)?

There is a DontZap option in the X configuration...
Code:
Option "DontZap" "1"
 
Old 07-04-2005, 09:04 AM   #4
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
I'm not the only one; looks like this may be a suse issue. I'll try the DontZap method for now, thanks!
 
Old 07-04-2005, 06:12 PM   #5
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Did you try this? http://lists.suse.com/archive/suse-l...-Sep/1733.html

Even if the above is not the right setting for you, the cause of your problem seems to be a wrong keyboard model specification.
 
Old 07-04-2005, 10:37 PM   #6
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
Nope. I'd seen that before, but didn't try it because my keyboard is set correctly in xorg.conf:

Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
 
Old 07-05-2005, 06:25 PM   #7
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Quote:
my keyboard is set correctly in xorg.conf
A) How can one know for sure?
B) Try xev to see what is going on when you press shift and/or backspace.
 
Old 07-05-2005, 09:35 PM   #8
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
I have a standard vanilla 101-key keyboard, no extra buttons, dials or anything not grey, square and sporting an ascii character. xorg.conf has Option "XkbModel" "pc101" ...what other options are there?

I'll try xev...is that something that one runs after one cuts out of X or before?
 
Old 07-06-2005, 06:19 PM   #9
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Quote:
is that something that one runs after one cuts out of X or before?
xev is a standard program for X. It will dump to stdout all the events that happen in its window. (this means an event for every one pixel mouse move, every key press and every key release)
 
Old 07-06-2005, 06:36 PM   #10
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
Heh, guess what? Looks like my upgrading to xorg fixed a whole host of problems, this one included. So everything's good
Thanks!
 
Old 07-22-2005, 03:11 PM   #11
Robert G. Hays
Member
 
Registered: Jan 2003
Location: Atlanta, Ga., USA
Distribution: Gentoo, Mandrake, ~others
Posts: 157

Rep: Reputation: 30
"The best Windows accelerator is that which works at 9.81m/s^2"

<GRIN!>

True, but only the Win media -- it's not the *computer's* fault, it's the fualt of whomever put Win on it in the first place.

Besides, doing only the media makes asmaller hole, more cheaply patched!

And yes, xorg seems to have gotten itself together in the last few months, thank $DEITY.
 
Old 07-22-2005, 03:25 PM   #12
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
Quote:
Besides, doing only the media makes a smaller hole, more cheaply patched!
Heheheh...I always think of that quote in conjunction with the gravity demonstration in Sideways Stories from Wayside School

In all honestly, though, I have to admit that Win2K wasn't all that bad...it at least had the advantage of being straightforward, assumed a degree of knowledge from its users, and wasn't all bubbly and round (as if its users would accidentally fall and hurt themselves on all the sharp edges...*sigh*). And it only bluescreens once a month or so (as opposed to XP, which will do so on command)! Cedega's still iffy for me, so I preserve a Win2K box to get my gaming fixes.

I think it's pretty funny that this post is #666 for me }:-> That's what I get for saying something nice about Windows!
 
Old 03-04-2006, 11:30 AM   #13
ErikdeBruijn
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Rep: Reputation: 0
Alternative solution to Shift-Backspace zapping X

Many people can run "xmodmap /usr/share/xmodmap/xmodmap.us" to fix the shift-backspace X resetting problem. But I my case it made other things worse/break or still resetted my X... so I found an alternative:

If you do this:
Code:
# xmodmap -pp -pk | grep BackSpace
It should show:
Code:
     22         0xff08 (BackSpace)      0xff08 (BackSpace)
But if there is something about zapping X beteen the parentheses, you should change it back to BackSpace:
Code:
# xmodmap -e "keycode 22 = BackSpace BackSpace"
Put this line into ~/.Xmodmap or .kde/Autostart/mystartups (and make the latter one executable) to make it persistent (for every boot).

This saved me from smashing my keyboard into the screen! I now have no problems at all with Dapper...

Quote:
Doing "xmodmap /usr/share/xmodmap/xmodmap.us" fixed the Shift|Backspace bug, but now my F12 hotkey and Ctrl+Alt+Workspace number hotkey doesn't work. Anyone else? That sucks!
--
Erik de Bruijn
Budgetdedicated.com
 
Old 03-04-2006, 11:31 AM   #14
ErikdeBruijn
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Rep: Reputation: 0
Alternative solution to Shift-Backspace zapping X

Many people can run "xmodmap /usr/share/xmodmap/xmodmap.us" to fix the shift-backspace X resetting problem. But I my case it made other things worse/break or still resetted my X... so I found an alternative:

If you do this:
Code:
# xmodmap -pp -pk | grep BackSpace
It should show:
Code:
     22         0xff08 (BackSpace)      0xff08 (BackSpace)
But if there is something about zapping X beteen the parentheses, you should change it back to BackSpace:
Code:
# xmodmap -e "keycode 22 = BackSpace BackSpace"
Put this line into ~/.Xmodmap or .kde/Autostart/mystartups (and make the latter one executable) to make it persistent (for every boot).

This saved me from smashing my keyboard into the screen! I now have no problems at all with Dapper...

Quote:
Doing "xmodmap /usr/share/xmodmap/xmodmap.us" fixed the Shift|Backspace bug, but now my F12 hotkey and Ctrl+Alt+Workspace number hotkey doesn't work. Anyone else? That sucks!
--
Erik de Bruijn
Budgetdedicated.com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mysql++ in combination with debina :~ freakin'me Linux - Software 0 10-08-2005 06:37 PM
A combination of sound cards devilkin Linux - Hardware 0 05-16-2005 11:29 PM
Using streams in combination with classes Zotty Programming 5 12-01-2004 09:09 AM
Combination Questions (XF86 and GNOME) ToothlessRebel Linux - Newbie 6 07-09-2004 05:06 PM
Is it a good combination to use ??? amit_28oct Programming 1 03-28-2004 11:29 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration