LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-04-2004, 08:39 PM   #1
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Rep: Reputation: 30
"mysqld ended"


after starting up my slackware system, I get this error at the login prompt:

040304 18:24:05 mysqld ended

After clicking enter, I'm given a login prompt which I can actually login to without recieving this error.

So the mysql daemon was ended. My question is why? And how do I get it to *not* end?

This is off of a clean slackware install, with mysql and all of the necessary libs included, so I have no idea why it would want to end.
 
Old 03-04-2004, 11:18 PM   #2
YMHiK
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware 2.6.5, Slackware 2.6.4, RedHat 9 2.4.20-8
Posts: 23

Rep: Reputation: 15
You may want to check your config details in your /etc/my.cnf
Once I got same problem, but I compiled mysql from sources and made clean install... the fix for me was to fix permission to tables(actual phisycal files) and set up corretly my.cnf
 
Old 03-05-2004, 02:02 AM   #3
ilhbutshm
Member
 
Registered: Jul 2003
Location: Europe
Distribution: Slackware 10.2
Posts: 104

Rep: Reputation: 15
I do this: ./configure --with-prefix=/usr/local/mysql and get this:

Quote:

Installing all prepared tables
040304 11:21:09 ./bin/mysqld: Shutdown Complete


To start mysqld at boot time you have to copy support-files/mysql.server
to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:
./bin/mysqladmin -u root password 'new-password'
./bin/mysqladmin -u root -h p166 password 'new-password'
See the manual for more instructions.

NOTE: If you are upgrading from a MySQL <= 3.22.10 you should run
the ./bin/mysql_fix_privilege_tables. Otherwise you will not be
able to use the new GRANT command!

You can start the MySQL daemon with:
cd . ; ./bin/mysqld_safe &

You can test the MySQL daemon with the benchmarks in the 'sql-bench' directory:
cd sql-bench ; perl run-all-tests

Please report any problems with the ./bin/mysqlbug script!

The latest information about MySQL is available on the web at
http://www.mysql.com
Support MySQL by buying support/licenses at https://order.mysql.com

Starting the mysqld server. You can test that it is up and running
with the command:
./bin/mysqladmin version
root@p166:/home/supr/sf/mysql-standard-4.0.18-pc-linux-i686# Starting mysqld daemon with databases from /home/supr/sf/mysql-standard-4.0.18-pc-linux-i686/data
040304 11:21:11 mysqld ended
the thing just stops here... what am I doing wrong?!

(fresh slack9.1 install..)
 
Old 03-05-2004, 05:37 PM   #4
nightwulf
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
From /etc/rc.d/rc.mysqld (from Slack 9.1 installation packages):

Quote:
# Before you can run MySQL, you must have a database. To install an initial
# database, do this as root:
#
# su - mysql
# mysql_install_db
#
# Note that step one is becoming the mysql user. It's important to do this
# before making any changes to the database, or mysqld won't be able to write
# to it later (this can be fixed with 'chown -R mysql.mysql /var/lib/mysql').
Tried this?

Regards,
nightwulf
 
Old 03-05-2004, 05:49 PM   #5
LeniuNYC
LQ Newbie
 
Registered: Feb 2004
Location: new york
Posts: 27

Rep: Reputation: 15
well, i was getting the same thing, it was annoying me for a whle and then i reinstalled slackware without the option ' to start mysqld at startup', and then i added the start at startup myself and everything is fine.
but im sure there's an easier way to do it :P
 
Old 03-06-2004, 01:01 AM   #6
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Original Poster
Rep: Reputation: 30
Thanks! I got it to work.

But now I'm getting another error. When I try to create a new database::

mysql /var/www/htdocs/score/score.sql


it gives me this::

ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO)



Any ideas?

-Thanks
 
Old 03-06-2004, 11:41 AM   #7
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Original Poster
Rep: Reputation: 30
Come on people, please I hate to bump this but I have no clue what to do.
 
Old 03-06-2004, 01:04 PM   #8
Qzukk
Member
 
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
Check your access settings. Did you set a password for the root@localhost account? (You aren't using a password when you try to connect there) Note that user "root" is different account from "root@localhost", maybe you should try connecting through the socket instead of to localhost via TCP.

If all else fails, there is an entire section on resetting your access table http://www.mysql.com/documentation/m...ng_permissions
 
Old 03-06-2004, 01:18 PM   #9
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Original Poster
Rep: Reputation: 30
Thankyou! I'm gonna see if I can fix this.
 
Old 03-07-2004, 06:17 PM   #10
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Original Poster
Rep: Reputation: 30
k, I set the password, but I'm still getting this:

root@localhost:~# mysql /var/www/htdocs/score/score.sql
ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO)
root@localhost:~#
root@localhost:~#
root@localhost:~#


I'm logged in as root@localhost, so shouldn't it not still be giving me this error?

Any help would be greatly appreciated

-Thanks!
 
Old 03-07-2004, 10:00 PM   #11
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Original Poster
Rep: Reputation: 30
okay, now its saying that it can't find mysql.sock, AND whenver I type:

mysqld_safe &

which should start it, it ends up saying:

root@localhost:~# mysqld_safe &
[1] 1567
root@localhost:~# Starting mysqld daemon with databases from /var/lib/mysql
040307 08:52:29 mysqld ended


[1]+ Done mysqld_safe
root@localhost:~#


What should I do? This is very confusing.

-Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"...incompatible pointer type" Can it be ended? lyd Programming 3 07-29-2005 02:43 PM
"mysqld ended" when trying to start mysql daemon guarriman Linux - General 1 01-19-2005 07:35 AM
Error: "mysqld dead but subsys locked" mikeshn Linux - Software 1 01-01-2004 05:18 PM
mysqld ended message on Slack... Vincent_Vega Slackware 1 12-20-2003 04:04 AM
mysqld ended.. xdrainox Slackware 9 10-02-2003 04:26 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration