LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-04-2003, 09:17 PM   #1
Bensoft Kill MS
Member
 
Registered: Jul 2003
Location: KY
Distribution: Red Hat 9
Posts: 65

Rep: Reputation: 15
My Optical Mouse (PS2) doesn't respond until it is moving at a certain speed...


When I start moving my mouse, it won't immediately respond unless I am moving it a certain speed. It doesn't do this in windows, so it isn't my computer hardware. Is there a certain command I can use to tweak it's sensitivity? My friend has the RH9, the exact version that I have, and he has a usb optical mouse and doesn't have this problem. When I connect my non optical mouse thought the ps2 port or the serial port (have a converter), it doesn't do it.

I can't connect my optical mouse through the serial port for some reason, not sure why, and when I flipped the mouse and keyboard ps2s nothing happened (didn't think it would, just thought I would try).

One thing i noticed was when I went into the mouse config and changed the type of mouse (did do that the second time and got same result when I clicked OK), the response was immediate, however after about half a screen of moving, it would jump to the bottom right. It did this when I tried it with my not optical mouse, so that jumping isn't cause the mouse is missing anything, or finding something that isn't there.

Help! My other mouse doesn't have a scroll wheel and my optical one does but I can't stand how it reacts in linux...
 
Old 11-04-2003, 09:20 PM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
post /etc/X11/XF86Config-4
 
Old 11-04-2003, 10:32 PM   #3
Bensoft Kill MS
Member
 
Registered: Jul 2003
Location: KY
Distribution: Red Hat 9
Posts: 65

Original Poster
Rep: Reputation: 15
Here's what you need I believe [not including the whole thing cause when I opened it up in notepad, it was all jumbled up (can't get online in linux yet)]

By on bootup when loading Mouse Console Services, I get "Spurious 8259A interrupt IRQ-7". It says ok and the mouse works, so I'm guessing it doesn't really matter. mmmm...change something in bios maybe?


# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"

Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Action Monitor CL-1566"
DisplaySize 260 200
HorizSync 30.0 - 66.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "RIVA TNT2"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Last edited by Bensoft Kill MS; 11-04-2003 at 10:42 PM.
 
Old 11-04-2003, 10:41 PM   #4
Nezzo
Member
 
Registered: Sep 2003
Distribution: Slackware, Ubuntu
Posts: 65

Rep: Reputation: 15
in your XF86Config file comment out the same line as i did below and restart X to see if that helps

Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
#InputDevice "DevInputMice" "AlwaysCore"
EndSection
 
Old 11-04-2003, 10:44 PM   #5
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
Comment this line out: InputDevice "DevInputMice" "AlwaysCore"
so : #InputDevice "DevInputMice" "AlwaysCore"

actually there is an option for mouse speed, but only for PS/2 not IMPS/2.
In case you need it:

Option "Resolution" "256"

That goes into the InputDevice section

Last edited by iceman47; 11-04-2003 at 10:47 PM.
 
Old 11-04-2003, 11:51 PM   #6
Bensoft Kill MS
Member
 
Registered: Jul 2003
Location: KY
Distribution: Red Hat 9
Posts: 65

Original Poster
Rep: Reputation: 15
Yeah I can change speed under mouse preferences I believe.

No, removing that line didn't work. Any other help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My USB mouse does not respond. soner Linux - Hardware 3 10-31-2004 09:40 AM
How to configure MS Optical PS2 Mouse railsfreak Linux - Hardware 3 03-19-2004 05:57 PM
Mouse pointer does not respond to mouse after boot??? nilsamon Fedora 2 03-12-2004 12:49 PM
Optical mouse pointer not moving instantly on RH9 oliwally Linux - Hardware 7 01-01-2004 07:05 AM
Is there a way to get the mouse to respond like it does in windows? VENTELTINTE Linux - General 1 12-23-2003 02:50 PM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration