LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-01-2009, 05:58 AM   #1
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
my firefox got hacked, messagebox / alert spam / lots of messageboxes


This is a rather strange occurrence, but yesterday while browsing the net (I admit the sites were not exactly friendly, so they may have been the culprits) using firefox I suddenly got spammed by messageboxes or firefox alert boxes or whatever they are, just hundreds of them all started opening and I couldn't close them. They opened about several hundred windows of the same message (it looked blank). I had to kill Xorg to stop it.

Anyone else had such an issue ?

I have Noscript and adblock installed, I disabled javascript from modifying anything about windows, and I don't think that I had enabled javascript on any site when this happened, but I may be wrong. This may have been triggered by javascript, or ever worse by some FF exploit that I don't know about.

Is there any way to limit the number of such alert messages or just disable them completely, I f'n hate them ! They remind me of Windoze

Anyway, I'll keep looking for a solution and will post it if I find it, but I'm just wondering if someone already knows it.

Last edited by H_TeXMeX_H; 12-01-2009 at 05:59 AM.
 
Old 12-01-2009, 06:08 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,043

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
Quote:
Originally Posted by H_TeXMeX_H View Post
I have Noscript and adblock installed,

Be default, noscript should lock any javascript that you don't explicitly enable, unless you have softened the configuration a bit or something, which you shouldn't. And javascript, as far as I know, is the only mechanism that firefox has to do this, since there's no ActiveX in Linux.

So, I'd start by either checking the noscript configuration or by completely cleaning all the firefox files in your home.
 
Old 12-01-2009, 06:18 AM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
The settings for noscript are as close to the default as can be, I have everything blocked by default.
 
Old 12-01-2009, 06:24 AM   #4
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Try changing dom.popup_maximum to a reasonably low number, such as 2. The default value in Firefox is 20, but there aren't many legitimate reasons for a web page to launch more than two popups at a time, and definitely not 20!

Also check privacy.popups.disable_from_plugins it should be set to 2 by default.

And double check Edit>Preferences>Content> Block Popups is checked.
 
Old 12-01-2009, 06:39 AM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by craigevil View Post
Try changing dom.popup_maximum to a reasonably low number, such as 2. The default value in Firefox is 20, but there aren't many legitimate reasons for a web page to launch more than two popups at a time, and definitely not 20!

Also check privacy.popups.disable_from_plugins it should be set to 2 by default.

And double check Edit>Preferences>Content> Block Popups is checked.
Ok, thanks, I changed it from 20 to 2, maybe this was the problem. What kinds of popups are these limiting ?

Either way popups are being blocked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox alert message - Ubuntu 9.04 mumblemike Linux - Software 2 06-28-2009 08:55 PM
Is my server sending spam ? (qmail question, lots of mails going out) phlampe Linux - Server 6 05-14-2009 03:53 AM
qmail - mail server hacked,sending spam - help.. > skate Linux - Server 8 07-29-2008 03:25 AM
displaying messageboxes in Linux lucky6969b Programming 3 03-29-2006 10:52 AM
java alert in firefox... questionasker Programming 1 05-04-2005 03:24 PM


All times are GMT -5. The time now is 07:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration