LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-12-2010, 05:28 AM   #1
gusblake
LQ Newbie
 
Registered: Feb 2010
Posts: 24

Rep: Reputation: 15
music goes to usb-audio, youtube sound goes to laptop speaker (hda-intel)


Hi,

when I play music in Rhythmbox, the sound comes out of my main speakers via a usb sound card (snd-usb-audio), but sound from the browser comes out of the laptop speakers (snd-hda-intel).

I have tried editing the sound cards' indexes in /etc/modprobe.d/alsa-base, but this didn't have any effect.

Is there a way I can completely disable a certain device or driver, or just make usb-audio the default, in order to force all sound to come out of the main speakers?

Cheers,
Gus
 
Old 04-12-2010, 06:47 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, in /etc/modprobe.d is there a file called black list?

If so add the name of the module to the list, like this

Code:
blacklist snd_hda_intel
this requires a reboot to check,

or see here for more...
http://linux.die.net/man/5/modprobe.conf
http://linux.die.net/man/8/modprobe
Quote:
modprobe [ -r ] [ -v ] [ -n ] [ -i ] [ modulename ... ]

-r --remove
This option causes modprobe to remove, rather than insert a module. If the modules it depends on are also unused, modprobe will try to remove them, too. Unlike insertion, more than one module can be specified on the command line (it does not make sense to specify module parameters when removing modules).

There is usually no reason to remove modules, but some buggy modules require it. Your kernel may not support removal of modules.

-v --verbose
Print messages about what the program is doing. Usually modprobe only prints messages if something goes wrong.

This option is passed through install or remove commands to other modprobe commands in the MODPROBE_OPTIONS environment variable.

-i --ignore-install --ignore-remove
This option causes modprobe to ignore install and remove commands in the configuration file (if any), for the module on the command line (any dependent modules are still subject to commands set for them in the configuration file). See modprobe.conf(5).

-n --dry-run
This option does everything but actually insert or delete the modules (or run the install or remove commands). Combined with -v, it is useful for debugging problems.
Another way is to use index=-2 in the file where you set the index before.

hope this helps, regards Glenn
 
1 members found this post helpful.
Old 04-12-2010, 08:47 AM   #3
gusblake
LQ Newbie
 
Registered: Feb 2010
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the detailed reply, adding the blacklist solved it.

Cheers,
Gus
 
Old 04-13-2010, 04:28 AM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Excellent.

Please mark you thread as solved, in the tread tools.

Regards Glenn

by the way index=-2, is "do not use"
 
Old 04-13-2010, 04:20 PM   #5
arturo393
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Rep: Reputation: 0
hi,i have the same problem. is there a way to use usb-audio as default instead of disable laptop speakers drivers?
 
Old 04-13-2010, 08:01 PM   #6
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi! Welcome to LQ arturo393!

There is a file called /etc/modprobe.conf

here you can (as root) add the modules you wish to use, and order them with index=
Code:
snd_usb_audio index=1
snd_hda_audio index=2
make sure the names are right, then append them to the end of the file. Reboot to check it works, for next time.

when the usb is not plugged in, it will default to the onboard sound.

For the best response, create a new thread for your question

If the directions above do not suffice.

Please read, How to ask a question. So we are given enough information on your system and problem

to offer an answer.

cheers, Glenn
 
Old 09-17-2010, 11:45 PM   #7
monkeyamongmen
LQ Newbie
 
Registered: Sep 2010
Posts: 1

Rep: Reputation: 0
Talking USB sound card fixed

Hey, I'm running some fairly recent Debian distro, and just used this to fix my cheapo '3D Sound' usb sound card. Flash now plays sound through my usb, which is great.

Thanks for the help.

Tom
 
  


Reply

Tags
laptop, sndhdaintel, sound, speakers, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP laptop w/ hda-intel - headphones/speaker problem. ocularb0b Linux - Hardware 6 11-15-2007 01:44 PM
Intel HDA Audio - No sound: With a Twist! person132 Linux - Hardware 2 04-21-2007 09:40 AM
New laptop, no sound. Fedora Core 6, intel-hda-audio ("Azalia") BogusTrumper Linux - Hardware 3 04-17-2007 12:27 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 1 07-05-2006 11:13 PM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration