LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-15-2004, 11:37 PM   #1
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Rep: Reputation: 30
Music CD's are not found. Slackware 10.


Whenever I try to use a program to play Music CD's it doesn't play. Can someone give me a reason, and how to resolve this. Or do you know of a good program?
 
Old 10-16-2004, 12:25 AM   #2
baldwonder
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, VectorLinux, FreeBSD,Xubuntu
Posts: 69

Rep: Reputation: 15
I was using the built-in CD player in Gnome, but since I have switched to Fluxbox I use workbone. It is a good program with a very simple interface (you use the number pad to control the music) that runs from the command line. I'm not sure if it is included in other distributions, but it is on Slackware 10 (CD1 I think). I can't remember which folder though. What problems are you having? Does the CD look like it is playing but you have no sound or does the program not recognise that you have a CD in the drive? Can you be more specific?
 
Old 10-16-2004, 01:14 AM   #3
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
When I try to mount the cd, I get this...

sh-2.05b$ mount /mnt/cdrom/
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems.
sh-2.05b$

And yes I do have workbone.

And yes I did a chmod 666 /dev/cdrom/ (and 777, and a+x)
 
Old 10-16-2004, 01:45 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
you can't mount audio CD's since they don't have a valid filesystem, you need to point your cd player app to the right drive, for example on my system it's /dev/cdrom or /dev/hdc. Also make sure that you have the right permissions to access the disk drive.
 
Old 10-16-2004, 02:08 AM   #5
baldwonder
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, VectorLinux, FreeBSD,Xubuntu
Posts: 69

Rep: Reputation: 15
what happens when you try this:

workbone -p1 -d /dev/cdrom

Does your CD-ROM activity light come on? Any errors?

Last edited by baldwonder; 10-16-2004 at 02:13 AM.
 
Old 10-16-2004, 02:50 AM   #6
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
CD Rom light activity, and I can't run it as a normal user, it says run chmod 666 /dev/cdrom for user previlages, even though I changed /etc/fstab.
 
Old 10-16-2004, 12:45 PM   #7
baldwonder
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, VectorLinux, FreeBSD,Xubuntu
Posts: 69

Rep: Reputation: 15
It sounds like the CD is playing, you just have no sound. Try this (as root)

# alsaconf

It should get your sound card setup and then run alsamixer or rexima to set the volume levels for everything.

As for why you can't run workbone as a normal user, I don't really know. What error did you get when you tried it?
 
Old 10-16-2004, 01:30 PM   #8
luminousnerd
Member
 
Registered: Oct 2004
Location: Nerdville
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
I have the same problem, but I use KDE, and prefer not to enter the terminal. Any suggestions?
 
Old 10-16-2004, 01:50 PM   #9
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Quote:
Originally posted by luminousnerd
I have the same problem, but I use KDE, and prefer not to enter the terminal. Any suggestions?
HUH,..................why not?? Did Mandrake disable it.............LOL
 
Old 10-16-2004, 01:57 PM   #10
luminousnerd
Member
 
Registered: Oct 2004
Location: Nerdville
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
No, its easy to get into the terminal and I know how, it's just I prefer not to. It makes me uncomfortable and it isn't easy.

 
Old 10-16-2004, 02:07 PM   #11
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Well, my sound has been working, and I did alsaconf again, it works. And workbone says...

as root plz do chmod 666 /dev/cdrom/ to give your self access to cdrom.

Hmmm.... *thinking hard* I tried gnome just recently, and its the only desktop to find the cd, but, its still doesn't play it, tho theres cdrom activity. I did, however, put my headphones in the cdrom sound port. But to no avail :[.

You know what! I think its because I didn't put that line in from my cdrom to that little AUX port on my motherboard. Could that be the problem?
 
Old 10-16-2004, 06:50 PM   #12
baldwonder
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, VectorLinux, FreeBSD,Xubuntu
Posts: 69

Rep: Reputation: 15
Definately! Connecting your CD-ROM to the AUX port (or any of the sound input ports) on your motherboard should fix it. I'm not sure what to do with the workbone problem, but if you use Gnome CD Player and it works, don't worry about it.
 
Old 10-16-2004, 07:47 PM   #13
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Damnit. Now I got to find one of those things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant play music CD's unclejessie77 Linux - Software 14 06-22-2005 11:30 PM
FC3 Music CD's carlgulliver100 Linux - Software 2 02-01-2005 02:06 PM
Why can't I play Music CD's sgtbob Linux - Newbie 12 01-30-2004 07:28 PM
music CD's in linux? e1000 Linux - General 8 01-14-2004 07:00 AM
can't mount music cd's gonus Linux - Hardware 8 12-01-2002 02:05 PM


All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration