LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-20-2011, 06:49 PM   #1
deeman
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Rep: Reputation: 0
Multiple Monitors with Xinerama, mouse is offset by a screen?


I'm trying to make the migration from windows to linuxMint. My system has four screens using two cards. I want to set it up to have a single desktop that I can drag windows from one screen to another. Nvidia Twinview works great for two screens but not for four. That leaves me with using xinerama. However I'm experiencing a glitch. When I setup even two screens (starting simple) the mouse and picture seem to be offset by a screen. So say I have a folder on the desktop. It appears to be located on the right screen but to open it I have to click in the same location on the left screen.

anyone have any ideas?

Here is my xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@allspice) Fri Feb 25 14:42:07 UTC 2011

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Mon Apr 18 15:14:00 PDT 2011

Section "ServerLayout"

# Removed Option "Xinerama" "0"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic VX2250 SERIES"
HorizSync 24.0 - 82.0
VertRefresh 50.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "ViewSonic VX2250 SERIES"
HorizSync 24.0 - 82.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GS"
BusID "PCI:3:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GS"
BusID "PCI:3:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
SubSection "Display"
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0; DFP-0: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP-0: 1920x1080_60_0 +0+0; DFP-0: 1920x1080 +0+0; DFP-0: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
 
Old 11-15-2011, 10:07 AM   #2
thebigmizzaz
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
Hi, did you find a solution to your problem? I am having the same problem now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xinerama, ATI and Multiple Monitors JediToren Linux - Hardware 2 07-31-2011 05:24 PM
Mouse going oveer dge of Xinerama screen 1 wilsonsamm Linux - Desktop 0 07-14-2008 09:57 AM
Between sessions: cut/paste, multiple on one screen, dual monitors Z505 Linux - General 0 04-03-2005 01:42 PM
Xinerama monitors are above each other Silent1 Linux - Software 1 12-28-2004 04:46 PM
Dual Monitors, Xinerama, multiple desktops and the like... del914 Linux - Hardware 1 12-09-2003 10:53 PM


All times are GMT -5. The time now is 07:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration