LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-21-2003, 04:17 AM   #1
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
mplayer works, gmplayer does not


I've read the docs for mplayer, searched the fora, and have done everything correctly as far as I know, and I can't get a GUI MPlayer to save my life. I don't personally care if I ever get it to work, but my wife is slowly converting over to Linux I'd like her to be able to use MPlayer and right now she's scared of command line (I've tried to convice her all she can do is screw up her own profile as I've set her permissions so she can't do anything else but she's still afraid). So, here's what I've done:

Before doing anything, I made sure I met all the requirements on MPlayer's site. I've got all the X packages including development. I downloaded MPlayer 0.90rc4, default skin, proton skin, no fonts. Everything works really well without the GUI. At the ./configure stage I threw it the --enable-gui option and make and make install went perfectly. I copied the default skin to /usr/local/share/mplayer/Skin and the same with the proton skin:

Code:
phyx@frankenstein:/usr/local/share/mplayer/Skin$ ls
default/  proton/
Now, when I run gmplayer as my user, I get the following:

Code:
phyx@frankenstein:/usr/local/share/mplayer/Skin$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc4-2.95.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices K6-2 (Family: 5, Stepping: 0)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX 3DNow

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/phyx/.mplayer/config
[cfg] read config file: /home/phyx/.mplayer/gui.conf
Reading config file /home/phyx/.mplayer/gui.conf: No such file or directory
vo: X11 running at 800x600 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/phyx/.mplayer/codecs.conf: can't open '/home/phyx/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /home/phyx/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/phyx/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/phyx/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
It never goes anywhere and nothing comes up. Even if I type gmplayer -vo xv movie.mpg I get the same thing. There are no errors or anything that I can find (other than the permissions thing which I'll do after I get it running as root--see below for root's output) and it seems to look in the right location according to the last line. Why this happens I have no idea--unless my skins shouldn't be in directories /default and /proton. If I hit CTRL+C I get a popup window that says:

Quote:
Fatal error!
MPlayer interrupted by signal 2 in module: unknown
When I run gmplayer -vo xv movie.mpg as root I get the following:

Code:
root@frankenstein:/home/phyx# gmplayer -vo xv movie.mpg
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc4-2.95.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices K6-2 (Family: 5, Stepping: 0)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX 3DNow

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: couldn't open the X11 display ()!
MPlayer GUI requires X11.
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config

Playing movie.mpg
MPEG-PS file format detected.
VIDEO:  MPEG1  352x240  (aspect 1)  30.00 fps  1024.0 kbps (128.0 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 16000->176400 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: couldn't open the X11 display ()!
Error opening/initializing the selected video_out (-vo) device.


Exiting... (End of file)
Anyone out there have a copy of their /usr/local/share/mplayer/Skin contents that wouldn't mind posting it? If not, anyone have any idea what the issue is? What would be preventing the X11 display from opening? I tried it with "gmplayer -vo x11 movie.mpg" and "gmplayer -vo X11 movie.mpg" still nothing. I must have recompiled mplayer about 10 times with this to make sure nothing was going wrong. Any help is appreciated as this is really starting to get under my skin--no pun intended.

Last edited by Texicle; 03-21-2003 at 04:19 AM.
 
Old 03-21-2003, 04:26 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
ok well it would seem that the Xfree86 devel pacakges haven't been installed. you say that they were but i can only guess that something went wrong when you did it. when you run ./configure check to see if X11 is recognised... that's what's missing, and if the X devel headers ARE installed then it should definitely pick that up.
 
Old 03-21-2003, 02:47 PM   #3
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
Thanks for the suggestion. I am 100% sure that the X devel. packages are installed, but I'll do them again. Each time I did the ./configure (both with and without the --enable-gui option) I checked ~/configure.log to make sure everything was detected properly but I might have overlooked it. I'll give it a try tonight hopefully and post the contents of configure.log regarding X11. I've heard so much about how difficult it is to get mplayer installed but I must say that after reading all the docs I have to disagree. MPlayer itself installs really well, it's just this GUI that's killing me for some reason. I'll reinstall the X devel. packages again and ./configure --enable-gui the mplayer and post the contents of the configure.log if it doesn't go right. I know you firmly believe in not running the GUI (judging from all your other posts in other threads)--and I agree, but would you know if my skins are set up correctly in my /usr/local/share/mplayer/Skin file? Should each skin be in its own subdirectory like mine are? Thanks for helping me out acid_kewpie.
 
Old 03-21-2003, 03:35 PM   #4
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Here's the output of ls in /usr/local/share/mplayer/Skin/default

about.png* font.fnt* load.png* pause.png* prev.png* sub.png*
back.png* font.png* main.png* playbar.png* README* symbols.fnt*
eqb.png* forward.png* menu.png* play.png* skin* symbols.png*
eq.png* fsb.png* menus.png* plb.png* stop.png* VERSION*
exit.png* iconify.png* next.png* pos.png* subload.png* volume.png*

All the files have the permissions set to 777 (everything is allowed) and are owned by the user mad_ady (not root). I believe that setting your permissions should solve the problem....

Or you can try copying the skin to ~/.mplayer/Skin

Keep us posted.

gmplayer runs beautifully and returns this message:

[mad_ady@home-33045 default]$ gmplayer -vo x11 -framedrop
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc4-3.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Duron SF Spitfire (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/mad_ady/.mplayer/config
[cfg] read config file: /home/mad_ady/.mplayer/gui.conf
Reading config file /home/mad_ady/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Disabling DPMS
Reading /home/mad_ady/.mplayer/codecs.conf: can't open '/home/mad_ady/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /home/mad_ady/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Failed to open /dev/rtc: Permission denied (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/mad_ady/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/mad_ady/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

Good luck
 
Old 03-21-2003, 05:25 PM   #5
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
Thanks mad_ady. I'll check all the permissions and set them accordingly. I'm going to double check my X devel packages as well. I'm not in front of my linux box but I'm pretty sure my /usr/local/share/mplayer/Skins/default shows the same thing. I don't know about the permissions yet.

Also, is it best to run gmplayer -vo x11 or does it really matter which vo to use? I'm going to check into the -framedrop option as well.

Thanks alot.
 
Old 03-21-2003, 06:00 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
x11 is slow and cpu hungry, the standard default would be xv, which is also part of the core of X itself.
 
Old 03-21-2003, 10:47 PM   #7
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
acid_kewpie, is there a way to check for x11 without having to recompile mplayer? My output of "mplayer -vo help" is as follows:

Available video output drivers:
xmga Matrox G200/G4x0/G550 overlay in X11 window (using /dev/mga_vid)
mga Matrox G200/G4x0/G550 overlay (/dev/mga_vid)
xv X11/Xv
x11 X11 ( XImage/Shm )
gl X11 (OpenGL)
gl2 X11 (OpenGL) - multiple textures version
dga DGA ( Direct Graphic Access V2.0 )
fbdev Framebuffer Device
svga SVGAlib
aa AAlib
png PNG file
jpeg JPEG file
gif89a animated GIF output
null Null video output
pgm PGM file
md5 MD5 sum
mpegpes Mpeg-PES file
yuv4mpeg yuv4mpeg output for mjpegtools (to "stream.yuv")
vesa VESA VBE 2.0 video output
xvidix X11 (VIDIX)

This shows that x11 is available. Could there still be a problem with my X devel packages or am I just doing something wrong? When I use "mplayer -vo xv movie.mpg" or "mplayer -vo x11 movie.mpg" it works flawlessly--just the gmplayer that is having difficulties.
 
Old 03-22-2003, 04:14 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
an idea... ok you're running windows as a normal user, but running mgplayer as root. run "xhost +localhost" and try again. it may well be that the X server is simply refusing to let someone else i.e. not the guy that actaully started X to use the display.
 
Old 03-22-2003, 12:28 PM   #9
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Texicle: I use x11 because I have a really old video card. I get no acceleration (no scaling and no nothing), but it works! If you have a 3d accelerator you can use other settings (such as dga).

-framedrop makes playing more fluid by dropping frams... It helps if you run movies on older pc's (such as mine!)

-hardframedrop REALLY looses frames and movie quality, but runs any movie!

Good luck & keep us posted
 
Old 03-24-2003, 12:24 AM   #10
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
I tried the xhost +localhost thing and no dice (although man xhost does have some interesting information on it). Thanks for the suggestion acid_kewpie.

mad_ady, I decided to change all default skin and proton skin files' permissions to 777 and then run gmplayer -vo xv and nothing. So I did it again with gmplayer -vo xv -framedrop and it worked like a charm. After I opened up the default skin I was able to go through the skin browser and hook up the proton skin. Thanks for the suggestion.

My wife will now not have to use the command line for movies and what not. All I have to do now is set it up on the XFCE menu and she'll be set.

Thank you both for following along on my issue and helping me out. I really appreciate it.
 
Old 03-24-2003, 11:06 AM   #11
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Hmm.. Strange... -framedrop shouldn't have anything to do with the skin! But if it works...

Question... Now do you have to run gmplayer with -framedrop, or does it start also without this option? If you have a fast pc, you shouldn't use it... (Better quality).

Anyways, glad I could help you!
However, keep an eye on your skin files because now everyone has permission to do anything to them! It's a possible security risk!
 
Old 03-24-2003, 02:48 PM   #12
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
I didn't try it without the framedrop option so I can't say for sure it wouldn't work without it. I'm going to give it a try tonight. My pc is an AMD k6-2/266 with only 128MB of RAM. It's not a fast pc.

I'm going to change the permissions to read and execute only so no one can jack with the files.

Thanks again.
 
Old 03-25-2003, 01:40 PM   #13
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Given you config I strongly suggest you leave the -framedrop on. I have an AMD Duron @ 750Mhz with 192MB RAM and if I play without it, I keep getting a nagging waring that tells me that the image is falling behind the sound in playback.

Try it to find out!

Good luck!
 
Old 03-26-2003, 02:13 AM   #14
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Original Poster
Rep: Reputation: 30
Thanks. I'll keep the -framedrop option going then.
 
Old 03-26-2003, 05:31 AM   #15
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
you know you can just put it in a config file /etc/mplayer.conf or ~/.mplayer/config

framedrop = yes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer works but not gmplayer gilq1927 Linux - Newbie 5 12-05-2004 05:38 PM
GMplayer only works as root Stan the caddy Linux - Software 5 09-21-2004 12:19 PM
mplayer works great, gmplayer won't load Trogdor Linux - Software 2 07-22-2004 07:24 PM
mplayer to gmplayer 7even Linux - Newbie 4 10-13-2003 05:52 AM
mplayer to gmplayer problems Harp00 Linux - Newbie 8 09-29-2003 04:07 PM


All times are GMT -5. The time now is 03:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration