LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-01-2004, 08:59 AM   #1
Vurguuz
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
mplayer: vidix doesnt recognize ATI Radeon 8500LE


I installed and compiled the sources for MPlayer-0.92 passing --disable-divx4linux to the ./configure script. Having an ATI Radeon 8500LE, I would like to use its TV-out support and the mplayer docs say that vidix is the best choice for this. Setting the proper suid bits for the mplayer binary, I run "mplayer -vo xvidix <filename>" and get this in the video section of the verbose output:

No vidix driver name provided, probing available ones!
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
[mga] No supported cards found
[mga] No supported cards found
vosub_vidix: Couldn't find working VIDIX driver
Error opening/initializing the selected video_out (-vo) device.

Im running Slack9.1 and therefore XFree86 ver 4.3.0.

Thanks for any tips or solutions.

Here is mplayer's config.mak:

# -------- Generated by configure -----------

LANG = C
TARGET_OS = Linux
DESTDIR =
prefix = $(DESTDIR)/usr/local
BINDIR = $(DESTDIR)/usr/local/bin
DATADIR = $(DESTDIR)/usr/local/share/mplayer
MANDIR = $(DESTDIR)/usr/local/man
CONFDIR = $(DESTDIR)/usr/local/etc/mplayer
LIBDIR = $(DESTDIR)/usr/local/lib
#AR = ar
CC = gcc
AWK = gawk
RANLIB = ranlib
INSTALL = install
# OPTFLAGS = -O4 -march=pentium4 -mcpu=pentium4 -pipe -fomit-frame-pointer -ffast-math
OPTFLAGS = -O4 -march=pentium4 -mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
EXTRA_INC =
STRIPBINARIES = yes



STREAMING = yes
STREAMING_LIVE_DOT_COM = no
STREAMING_LIB = -lnsl
VIDIX = yes
PP_LIB = postproc/libpostproc.a
SHARED_PP = no
CONFIG_RISKY = yes
LIBMENU = no
I18NLIBS =

OPENDIVX = no

UNRARLIB = yes

PNG = yes
JPEG = yes
GIF = yes

EXTRA_LIB =
Z_LIB = -lz
HAVE_MLIB = no
WIN32_LIB =
STATIC_LIB =

X11_INC = -I/usr/X11/include
X11DIR = -L/usr/X11R6/lib -lXext -lX11 -lnsl

# for libavcodec:
SRC_PATH=.

# video output
X_LIB = -lGL -lXxf86dga -lXv -lXxf86vm -lXinerama -L/usr/X11R6/lib -lXext -lX11 -lnsl -lmad -lnsl
GGI_LIB =
MLIB_LIB =
MLIB_INC =
DXR2_INC =
DVB_INC =
PNG_LIB = -lpng -lz
JPEG_LIB = -ljpeg
GIF_LIB = -lungif
SDL_LIB = -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread
SVGA_LIB = -lvgagl -lvga -lm
AA_LIB =

# audio output
ALSA_LIB = -lasound -ldl -lpthread
NAS_LIB =
ARTS_LIB =
ARTS_INC =
ESD_LIB =
ESD_INC =
SGIAUDIO_LIB =

# input/demuxer/codecs
TERMCAP_LIB = -ltermcap
LIRC_LIB =
CSS_USE = no
CSS_LIB = -Llibmpdvdkit2 -lmpdvdkit
DVDKIT = no
DVDKIT2 = yes
DVDKIT_SHARED = no
SDL_INC = -I/usr/include/SDL -D_REENTRANT
W32_DEP = loader/libloader.a
W32_LIB = loader/libloader.a
DS_DEP = loader/dshow/libDS_Filter.a loader/dmo/libDMO_Filter.a
DS_LIB = loader/dshow/libDS_Filter.a loader/dmo/libDMO_Filter.a
AV_DEP = libavcodec/libavcodec.a
AV_LIB = libavcodec/libavcodec.a
FAME = no
FAME_LIB =
MP1E_DEP =
MP1E_LIB =
ARCH_LIB = -lpthread -ldl -rdynamic
XVID = no
XVID_LIB =
DECORE_LIB =
MENCODER = yes
ENCORE_LIB =
DIRECTFB_INC =
DIRECTFB_LIB =
CDPARANOIA_INC =
CDPARANOIA_LIB =
FREETYPE_INC = -I/usr/include/freetype2
FREETYPE_LIB = -lfreetype -lz
FRIBIDI_INC =
FRIBIDI_LIB =
LIBLZO_LIB=
MAD_LIB = -lmad
VORBIS_LIB = -lvorbis -logg
FAAD_LIB =
SMBSUPPORT_LIB =
XMMS_PLUGINS = no
XMMS_LIB =
MACOSX = no
MACOSX_FRAMEWORKS =

# --- Some stuff for autoconfigure ----
TARGET_ARCH_X86 = yes
TARGET_CYGWIN = no
TARGET_CPU=686
TARGET_MMX = yes
TARGET_MMX2 = yes
TARGET_3DNOW = no
TARGET_3DNOWEX = no
TARGET_SSE = yes
TARGET_ALTIVEC = no

# --- GUI stuff ---
GTKLIB =
GLIBLIB =
GTK_LIBS =
GUI = no
DEBUG = -DDEBUG
 
Old 02-01-2004, 09:36 AM   #2
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
well, radeon cards are generally not well supported in linux, which drivers are you using? you could always pick up atitvout and use that or you can use the ati-gatos drivers and skip the mplayer tvout part entirely with atitvout it wont be made for your card so i cant say if it will work perfectly (or at all) my radeon 7500 is not supported but i can get tvout using atitvout -f t hopefully one of these options should work try the gatos drivers first
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[ATI radeon 9600 XT] comb with suse 9.2 and cedega 4.2.1 just doesnt work? mephesto Linux - Hardware 10 04-06-2005 07:19 PM
ATI RADEON 7500 pci doesnt work with SUSE9.1 REDHAT9 darrensnow Linux - Hardware 0 09-04-2004 05:34 PM
ATI 8500LE Tv out? moly82 Linux - Software 0 12-24-2003 09:30 AM
Problems with ATI radeon 8500LE XFree86 and 3d graphics TVDC Mandriva 4 08-27-2003 09:23 AM
xFree86 and ATI Radeon 8500LE Saeven Linux - Hardware 2 05-28-2002 01:29 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration