LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2004, 12:02 PM   #1
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Rep: Reputation: 15
Mplayer Problems


I recently downloaded and installed Mplayer and I can't get it to work. Any video I open (including DVDs) comes back with "Error opening/initializing the selected video_out (-vo) device." Anyone know how to get this working?
 
Old 01-20-2004, 12:10 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you need to chose a valid video ouput....

there is a fairly common cause for this, which might be relevant here.... mplayer detects the posisble outputs when you compile it, and so if you do now have X devel libraries installed mplayer will not be able to be compiled with suitable video outputs.... if you are unable to open anything still, run mplayer from a terminal and post the FULL output.....
 
Old 01-20-2004, 12:18 PM   #3
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Original Poster
Rep: Reputation: 15
I got this as an RPM package, didn;t compile it. What then do I select as a video output??
 
Old 01-20-2004, 12:58 PM   #4
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 46
Hi there,

as acid_kewpie said... you should put the output... how we can know what is going on???

only as example, try something like...

mplayer -vo xv etc ...

can work...
regards
 
Old 01-20-2004, 01:09 PM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
type:
mplayer -vo help to get a list of all different video output devices ... and just like slackie said, when you see the different ones, just type something like:
mplayer -vo x11 movie.avi
and if this doesn't work, then do as stated and post the actual error ...
 
Old 01-20-2004, 02:40 PM   #6
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Original Poster
Rep: Reputation: 15
I got it! Thanks for the help!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer/Mplayer-plugin problems Buffbannana049 Fedora 3 07-13-2005 12:22 AM
problems with mplayer vatti Linux - Software 12 03-29-2005 04:18 PM
mplayer problems Dro Linux - Software 2 05-21-2004 04:51 PM
MPlayer problems... rcarr Linux - Newbie 3 09-24-2003 09:25 AM
having certain problems with mplayer saturn_vk Linux - Software 3 02-14-2003 08:04 PM


All times are GMT -5. The time now is 10:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration