LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-03-2009, 01:59 PM   #1
Mleahy
Member
 
Registered: Jan 2004
Posts: 43

Rep: Reputation: 15
Mplayer keeps resetting volume to max


Hello all,

I recently upgraded to Fedora 12 (x86_64), using the KDE desktop, and mplayer installed from the repos provided by rpmfusion.org.

I've found that every time I start playing a video file in mplayer, no matter what I have the volume set at for the desktop (in KMix), mplayer resets it to maximum...blasting my ears each time. If I turn down the volume in mplayer, it goes back to max the next time anyway. I checked the config in /etc/mplayer/mplayer.conf, and there doesn't seem to be any setting in there that would set a default volume level. I've also cleared the .mplayer folder in my home directory and that also has no effect.

It would be ideal if it just started with whatever volume I already had set for the master volume in KMix (as was the behaviour I've expected from other configurations I've used).

Does anyone have any suggestions?
 
Old 12-04-2009, 03:36 PM   #2
code933k
Member
 
Registered: Aug 2007
Location: Bogotá, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
Post

If your problem is mplayer, not Kmplayer check out whether your
$HOME/.mplayer/config
Code:
 ao=alsa
is in place.

If that doesn't work for you, try:
Code:
ao=alsa:device=plug=pcm
or
Code:
ao=alsa:device=plug=default
or
Code:
ao=alsa:device=pcm=default
Good luck.
 
Old 12-06-2009, 03:11 AM   #3
Mleahy
Member
 
Registered: Jan 2004
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks - ao=alsa was sufficient for mplayer.

In the config for gmplayer (~/.mplayer/gui.conf), I had to set the following as well:

ao_driver = "alsa:device=default"
ao_alsa_mixer = "default"
ao_alsa_mixer_channel = "Master"
ao_alsa_device = "default"
 
Old 12-06-2009, 11:41 AM   #4
code933k
Member
 
Registered: Aug 2007
Location: Bogotá, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
I am glad to hear that. Please mark this post SOLVED/CLOSED then.
Cheers.
 
  


Reply

Tags
alsaconf, mplayer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to pack rar of a 160GB Hdd without volume dependencies and with 4.2GB max. size? frenchn00b Linux - General 4 08-31-2008 03:36 PM
How to start mplayer with reduced volume to 70pct ? mplayer -volume ? frenchn00b Linux - General 1 03-29-2008 08:29 AM
sound will only come out at max volume :( my ears hurt :P nkoplm Linux - Newbie 2 08-13-2007 01:51 PM
max logical volume size for dell 2850 server jcai Linux - General 1 06-09-2006 12:22 AM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration