LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mplayer keeps resetting volume to max (http://www.linuxquestions.org/questions/linux-software-2/mplayer-keeps-resetting-volume-to-max-773269/)

Mleahy 12-03-2009 01:59 PM

Mplayer keeps resetting volume to max
 
Hello all,

I recently upgraded to Fedora 12 (x86_64), using the KDE desktop, and mplayer installed from the repos provided by rpmfusion.org.

I've found that every time I start playing a video file in mplayer, no matter what I have the volume set at for the desktop (in KMix), mplayer resets it to maximum...blasting my ears each time. If I turn down the volume in mplayer, it goes back to max the next time anyway. I checked the config in /etc/mplayer/mplayer.conf, and there doesn't seem to be any setting in there that would set a default volume level. I've also cleared the .mplayer folder in my home directory and that also has no effect.

It would be ideal if it just started with whatever volume I already had set for the master volume in KMix (as was the behaviour I've expected from other configurations I've used).

Does anyone have any suggestions?

code933k 12-04-2009 03:36 PM

If your problem is mplayer, not Kmplayer check out whether your
$HOME/.mplayer/config
Code:

ao=alsa
is in place.

If that doesn't work for you, try:
Code:

ao=alsa:device=plug=pcm
or
Code:

ao=alsa:device=plug=default
or
Code:

ao=alsa:device=pcm=default
Good luck.

Mleahy 12-06-2009 03:11 AM

Thanks - ao=alsa was sufficient for mplayer.

In the config for gmplayer (~/.mplayer/gui.conf), I had to set the following as well:

ao_driver = "alsa:device=default"
ao_alsa_mixer = "default"
ao_alsa_mixer_channel = "Master"
ao_alsa_device = "default"

code933k 12-06-2009 11:41 AM

I am glad to hear that. Please mark this post SOLVED/CLOSED then.
Cheers.


All times are GMT -5. The time now is 10:13 AM.