LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-03-2004, 07:47 AM   #1
robertoneto123
Member
 
Registered: Sep 2003
Distribution: Red Hat, Conectiva Linux
Posts: 32

Rep: Reputation: 15
MPLAYER just plays 3 sec per time


Hello,

I've installed the mplayer from a mandrake 9.2 rpm. I'm trying to play a lot of video files (.mpeg and .avi), but all that I got is 3sec movie. Then, mplayer pauses. If I click on "play" of gmplayer, more 3 secs of the movie are shown.

Does anyone have a clue of this problem?
 
Old 04-03-2004, 08:34 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Start gmplayer from the command line and watch the output. Error messages in mplayer are often verbous and suggest what can be done to remedy the problem.


Håkan
 
Old 04-03-2004, 09:39 AM   #3
robertoneto123
Member
 
Registered: Sep 2003
Distribution: Red Hat, Conectiva Linux
Posts: 32

Original Poster
Rep: Reputation: 15
Well, I did it... the results are bellow.

The only clue that I saw was:
Quote:
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Where must I put it? I know that is not on bash.profile, is it correct?

And I found something that does not seems right for a newbie:

Quote:
The selected video_out device is incompatible with this codec.
VDecoder init failed
Does it have anything to do? If so, how can I solve it?

Thanks!

(the full messages are shown bellow)
Quote:
MPlayer 0.91-3.3.1 (C) 2000-2003 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/roberto/.mplayer/config
[cfg] read config file: /home/roberto/.mplayer/gui.conf
Reading config file /home/roberto/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
Reading /home/roberto/.mplayer/codecs.conf: can't open '/home/roberto/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/roberto/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/roberto/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 52 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/roberto/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'

Playing /mnt/win_c2/clips/the Corrs/The Corrs with Bono of U2 - Summer Wine(1).mpeg
Cache fill: 0,00% (0 bytes) MPEG-PS file format detected.
VIDEO: MPEG1 352x240 (aspect 12) 29,97 fps 1150,0 kbps (143,8 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMXEXT for IDCT transform
libmpeg2: Using MMXEXT for motion compensation
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO: [xv] 352x240 => 352x264 Planar YV12 [fs]
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
Successfully enabled DPMS,115 ct: 0,000 8/ 8 0% 0% 0,0% 0 0 52%

Exiting... (Exit)
 
Old 04-03-2004, 11:12 AM   #4
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
try:
mplayer -vo xv your_file_name_here
 
Old 04-03-2004, 11:45 AM   #5
robertoneto123
Member
 
Registered: Sep 2003
Distribution: Red Hat, Conectiva Linux
Posts: 32

Original Poster
Rep: Reputation: 15
Thumbs down

It does not work...

Quote:
MPlayer 0.91-3.3.1 (C) 2000-2003 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/roberto/.mplayer/config
Reading /home/roberto/.mplayer/codecs.conf: can't open '/home/roberto/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/roberto/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/roberto/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 52 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing /mnt/win_c2/clips/the Corrs/The Corrs - Breathless.mpeg
Cache fill: 0,00% (0 bytes) MPEG-PS file format detected.
VIDEO: MPEG1 352x288 (aspect 8) 25,00 fps 1600,0 kbps (200,0 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Error opening/initializing the selected video_out (-vo) device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 Internet very slow (<1kb/sec) while windows got 50k/sec SafeTechs Mandriva 13 09-01-2006 04:07 PM
RedHat AS 3, system time delay 3 sec everyday jingle_mj Linux - General 5 11-01-2005 11:48 PM
redhat AS 3.0, system time delays 3 sec everyday. jingle_mj Red Hat 1 11-01-2005 10:54 PM
Sound only plays from one app at a time h8trix Linux - Hardware 4 05-31-2005 01:50 AM
mplayer plays in french BruceCadieux Linux - Software 7 12-31-2002 10:00 PM


All times are GMT -5. The time now is 06:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration