LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mplayer install using YUM fails (http://www.linuxquestions.org/questions/linux-software-2/mplayer-install-using-yum-fails-614970/)

skie_knite007 01-20-2008 10:43 AM

Mplayer install using YUM fails
 
Hi folks,

I tried installing mplayer using yum on my fedora 8 . It fails showing the following error:
--> Finished Dependency Resolution
Error: Missing Dependency: libdvdnavmini.so.4 is needed by package mplayer
Error: Missing Dependency: recode is needed by package enca
Error: Missing Dependency: libfribidi.so.0 is needed by package mplayer
Error: Missing Dependency: librecode.so.0 is needed by package enca
Error: Missing Dependency: libslang-utf8.so.1 is needed by package aalib
Error: Missing Dependency: libcaca.so.0 is needed by package mplayer
Error: Missing Dependency: libcucul.so.0 is needed by package mplayer


Won't yum resolve dependencies???

Please help me in solving this problem!!!!!!!!!!!!

sycamorex 01-20-2008 11:00 AM

As far as I remember mplayer is part of the Livna repository? Perhaps it's not enabled on your system

skie_knite007 01-20-2008 11:05 AM

The package livna-release-8-1 is already installed.
But still the problem persists

deepumnit 01-20-2008 11:14 AM

Check your repo file. I have successfully installed MPlayer using yum utility of Fedora 8.

skie_knite007 01-20-2008 11:21 AM

I ve got the following in my yum.repos.d directory
fedora-development.repo fedora-updates-testing.repo mirrors-rpmforge
Fedora-install-media.repo livna-devel.repo rpmforge.repo
fedora.repo livna.repo
fedora-updates.repo livna-testing.repo

Please tell me which repo did u use...

deepumnit 01-20-2008 11:36 AM

My /etc/yum.repos.d/fedora.repo looks like:

Code:

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY


skie_knite007 01-20-2008 11:49 AM

Its the same for me...

What else could be wrong?

custangro 01-20-2008 12:02 PM

Hmmm....me to....interesting....maybe try...

Code:

yum -y update && yum -y install mplayer

skie_knite007 01-20-2008 12:05 PM

:( Still its not working
Quote:

[root@localhost firefox]# yum -y update && yum -y install mplayer
Setting up Update Process
No Packages marked for Update
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mplayer.i386 0:1.0-0.88.rc2.lvn8 set to be updated
--> Processing Dependency: libcucul.so.0 for package: mplayer
--> Processing Dependency: liblzo2.so.2 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: liblirc_client.so.0 for package: mplayer
--> Processing Dependency: libdvdread.so.3 for package: mplayer
--> Processing Dependency: libdvdnavmini.so.4 for package: mplayer
--> Processing Dependency: libenca.so.0 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
--> Processing Dependency: libxvidcore.so.4 for package: mplayer
--> Processing Dependency: libdca.so.0 for package: mplayer
--> Processing Dependency: libaa.so.1 for package: mplayer
--> Running transaction check
---> Package lirc.i386 0:0.6.6-4.1.fc3.rf set to be updated
---> Package libdvdread.i386 0:0.9.7-1.fc3.rf set to be updated
--> Processing Dependency: libdvdcss >= 1.2.5 for package: libdvdread
---> Package lzo2.i386 0:2.02-2.fc3.rf set to be updated
---> Package mplayer.i386 0:1.0-0.88.rc2.lvn8 set to be updated
--> Processing Dependency: libcucul.so.0 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: libdvdnavmini.so.4 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
---> Package libdca.i386 0:0.0.5-2.lvn8 set to be updated
---> Package xvidcore.i386 0:1.1.3-1.lvn8 set to be updated
---> Package aalib.i386 0:1.4.0-5.1.fc3.rf set to be updated
--> Processing Dependency: libslang-utf8.so.1 for package: aalib
---> Package enca.i386 0:1.9-3.fc3.rf set to be updated
--> Processing Dependency: librecode.so.0 for package: enca
--> Processing Dependency: recode for package: enca
--> Running transaction check
---> Package libdvdcss.i386 0:1.2.9-4.lvn6 set to be updated
---> Package mplayer.i386 0:1.0-0.88.rc2.lvn8 set to be updated
--> Processing Dependency: libcucul.so.0 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: libdvdnavmini.so.4 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
---> Package aalib.i386 0:1.4.0-5.1.fc3.rf set to be updated
--> Processing Dependency: libslang-utf8.so.1 for package: aalib
---> Package enca.i386 0:1.9-3.fc3.rf set to be updated
--> Processing Dependency: librecode.so.0 for package: enca
--> Processing Dependency: recode for package: enca
--> Finished Dependency Resolution
Error: Missing Dependency: libdvdnavmini.so.4 is needed by package mplayer
Error: Missing Dependency: recode is needed by package enca
Error: Missing Dependency: libfribidi.so.0 is needed by package mplayer
Error: Missing Dependency: librecode.so.0 is needed by package enca
Error: Missing Dependency: libslang-utf8.so.1 is needed by package aalib
Error: Missing Dependency: libcaca.so.0 is needed by package mplayer
Error: Missing Dependency: libcucul.so.0 is needed by package mplayer




custangro 01-20-2008 02:53 PM

A long shot...but try...

Code:


yum install ibdvdnavmini.so.4 recode libfribidi.so.0 librecode.so.0 libslang-utf8.so.1 libcaca.so.0 libcucul.so.0 && yum -y install mplayer


skie_knite007 01-20-2008 07:36 PM

Yup I tried that.. but the dependent packages are unavailable in the repo.


No package ibdvdnavmini.so.4 available.
No package recode available.
No package libfribidi.so.0 available.
No package librecode.so.0 available.
No package libslang-utf8.so.1 available.
No package libcaca.so.0 available.
No package libcucul.so.0 available.

lazlow 01-20-2008 08:19 PM

You have a repo conflict.

It often happens when you mix third party repos. In this case you have rpmforge and Livna (which often conflict). What happens is this: Package A from Livna is not exactly the same as Package A from rpmforge. Now you go to install Package B from Livna which requires Package A but you have Package A installed from rpmforge, so yum spits out the error that a dependency(Package A from Livna) is not there. You can most easily get around this by using only one third party repo.

deepumnit 01-21-2008 12:42 AM

Code:

Error: Missing Dependency: libdvdnavmini.so.4 is needed by package mplayer
Error: Missing Dependency: recode is needed by package enca
Error: Missing Dependency: libfribidi.so.0 is needed by package mplayer
Error: Missing Dependency: librecode.so.0 is needed by package enca
Error: Missing Dependency: libslang-utf8.so.1 is needed by package aalib
Error: Missing Dependency: libcaca.so.0 is needed by package mplayer
Error: Missing Dependency: libcucul.so.0 is needed by package mplayer

Yeah, Lazlow gave the reason for this.

skie_knite007 01-21-2008 10:00 AM

lazlow,

I disabled rpmforge and tried using the repo livna alone. Still the problem persists.

Similarly i tried with rpmforge alone.....but in vain.....

philwynk 01-21-2008 04:50 PM

Odd... On my new Fedora 8 install, I just installed the livna rpm (http://rpm.livna.org/livna-release-8.rpm), and then simply "yum install mplayer," and it installed without a hitch.


All times are GMT -5. The time now is 04:58 PM.