LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-24-2005, 03:41 AM   #1
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Rep: Reputation: 0
Mplayer install error on FC4 x86_64


I am trying to install mplayer on 64 bit Fedora Core 4. I could not find a built version so I downloaded the source RPM. When I try to build it I get an error that reads:

Error: X11 support required for GUI compilation

Can someone tell me a worError: X11 support required for GUI compilation.

There are no graphics drivers yet for this machine (ATI Radeon Xpress 200m), so I am running in 1024x768. I am a linux newbie so I apologize if this is something incredibly stupid.


Leonard
 
Old 06-24-2005, 04:09 AM   #2
a1ex_007
LQ Newbie
 
Registered: Mar 2005
Location: Imphal
Distribution: Fedora Core 3 x86_64
Posts: 26

Rep: Reputation: 15
Well, i had the same problem. Well the thing is that u need to add an option while running the configure script.

$ ./configure --enable-gui --extra-libdirs=/usr/lib64


The thing is FC ( x86_64 architecture) has two lib directories /usr/lib and /usr/lib64 and the mplayer source is meant for 32-bit OS and to make it compile on a 64-bit OS u need to do some messing up.

Try this and reply whether this works or not.
 
Old 06-26-2005, 08:13 PM   #3
lynn_dylan
LQ Newbie
 
Registered: Jun 2005
Distribution: FC4
Posts: 1

Rep: Reputation: 0
a1x_007,

I'm having the same problem. I am also new to linux and was following a guide that told me I needed to add the option "--cc=gcc32" in order to get MPlayer to compile with GCC3.2 instead of GCC4.0. If I type

$ ./configure --enable-gui --extra-libdirs=/usr/lib64

like you said, without adding the GCC3.2 option, I get a very distinct error message telling me that I must "--disable-gcc-checking". If I use the "--cc=gcc32" option in conjunction with what you suggested above, I am told this:

Detected operating system: Linux
Detected host architecture: x86_64
Checking for gcc32 version ... 3.2.3, ok
Checking for host cc ... gcc32
Checking for assembler support of -pipe option ... yes
Unknown parameter: --extra-libdirs=/usr/lib64

When typed ./configure --help there was a similar option listed, "--with-extralibdir=DIR", so I used it replacing "DIR" with "/usr/lib64" only to recieve the same error message,

Error: X11 support required for GUI compilation

Even if I compile with the "--disable-gcc-checking" option it still gives me that damn message. If you have any more suggestions, I will be extremely grateful. I apologize for my ignorance, but I'm trying so please help me out.

Thanks,
Lynn
 
Old 06-26-2005, 08:45 PM   #4
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Original Poster
Rep: Reputation: 0
still not working

Before I was using the source RPM and didn't know how to add those options with the RPM, so I downloaded the 1.0pre7 tarball of the source. When I was using the config option it was not detecting gcc 4.0 (which I have because I use FC4). I disabled the gcc-checking and used the options you gave me and I still get the "Need X11 support"

Here is the end of the output:
Checking for Subtitles sorting ... yes
Checking for XMMS inputplugin support ... no
Checking for inet6 ... yes
Checking for gethostbyname2 ... yes
Checking for GUI ... yes

Error: X11 support required for GUI compilation
 
Old 06-26-2005, 09:40 PM   #5
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Original Poster
Rep: Reputation: 0
Checking configure.log I found these errors:

/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libXext.so when searching for -lXext
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libXext.a when searching for -lXext

I was able to make config finish by adding the option --with_extralibdir=/usr/X11R6/lib64
 
Old 06-26-2005, 09:50 PM   #6
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Original Poster
Rep: Reputation: 0
More errors

Ok... Now I get errors when I run make.

URCE -c -o libpostproc/postprocess.o libpostproc/postprocess.c
In file included from libpostproc/postprocess.c:655:
libpostproc/postprocess_template.c: In function 'do_a_deblock_MMX2':
libpostproc/postprocess_template.c:2901: error: memory input 4 is not directly addressable
libpostproc/postprocess_template.c: In function 'postProcess_MMX2':
libpostproc/postprocess_template.c:3510: warning: pointer targets in passing argument 6 of 'blockCopy_MMX2' differ in signedness
libpostproc/postprocess_template.c:3656: warning: pointer targets in passing argument 6 of 'blockCopy_MMX2' differ in signedness
libpostproc/postprocess_template.c:3757: warning: pointer targets in passing argument 4 of 'tempNoiseReducer_MMX2' differ in signedness
libpostproc/postprocess_template.c:3781: warning: pointer targets in passing argument 4 of 'tempNoiseReducer_MMX2' differ in signedness
libpostproc/postprocess_template.c:3481: error: memory input 4 is not directly addressable
libpostproc/postprocess_template.c:3481: error: memory input 5 is not directly addressable
libpostproc/postprocess_template.c:3627: error: memory input 4 is not directly addressable
libpostproc/postprocess_template.c:3627: error: memory input 5 is not directly addressable
make[1]: *** [libpostproc/postprocess.o] Error 1
make[1]: Leaving directory `/home/lenny/dl/Mplayer/MPlayer-1.0pre7/libavcodec'
make: *** [libavcodec/libavcodec.a] Error 2

I'm ready to look for some other media players
 
Old 06-28-2005, 12:53 AM   #7
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Original Poster
Rep: Reputation: 0
I would still like to know how to fix this. Has anybody else sucessfully installed this app on FC4 64? I am not sure what the problem is now. I don't know if it has to do with me having to disable the gcc checking. Any help would be appreciated.
 
Old 07-07-2005, 08:07 AM   #8
Daniel72
LQ Newbie
 
Registered: Jul 2005
Location: Germay
Posts: 1

Rep: Reputation: 0
Hi,

I had the same problem on FC4. I installed

compat-gcc-32-3.2.3-47.fc4.i386.rpm

and used

./configure --enable-gui --cc=gcc32

to configure. It worked.

Best regards, Daniel
 
Old 07-07-2005, 12:26 PM   #9
ltracy
LQ Newbie
 
Registered: Jun 2005
Location: Seattle
Distribution: Fedora
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks. It worked on mine with the command

./configure --cc=gcc32 --enable-gui --with-extralibdir=/usr/lib64 --with-extralibdir=/usr/X11R6/lib64

Or at least something very close to that .
 
Old 10-09-2005, 08:55 PM   #10
mindsport
Member
 
Registered: Apr 2005
Location: Florida
Distribution: Slackware 13.1-64bit / 2.6.33.4
Posts: 45

Rep: Reputation: 17
this crap has been bothering me for a week now, I appreciate everyone on here and this superb forum.. I second that "./configure --cc=gcc32 --enable-gui --with-extralibdir=/usr/lib64 --with-extralibdir=/usr/X11R6/lib64" works perfectly, thanks guys.
 
Old 12-17-2005, 03:07 AM   #11
tek1024
Member
 
Registered: Sep 2003
Posts: 49

Rep: Reputation: 15
Thumbs up I concur!

I'd like to echo that happy sentiment, I just compiled and installed MPlayer successfully using that little line (and blogged about it, go figure).

Thanks!
 
Old 01-10-2006, 06:36 PM   #12
revof11
Member
 
Registered: Nov 2003
Location: Macungie, PA
Distribution: Fedora Core 9, Gentoo 2008.0
Posts: 108

Rep: Reputation: 15
Talking

Rock on.
That works most excellently.

I was pining over the problem for ages.
I, like, heart LinuxQuestions.org
 
Old 01-18-2006, 07:45 AM   #13
elsabio
LQ Newbie
 
Registered: Mar 2005
Location: england
Distribution: handbuilt (reliable), FC3 (flakey as a piecrust)
Posts: 9

Rep: Reputation: 0
Just to add a little spice to this thread: Has anyone been successful in building a 32 bit version of mplayer on an x86_64 platform? The RealAudio codec (amongst others) is 32 bits only, and I was in the habit of using this before upgrading to a 64-bit box.

The intuitive configure line of:

CFLAGS="-m32 -march=athlon-4" ./configure --cc=gcc32

(I don't need the gui)

fails in the compile with:

gcc32 -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -m32 -march=athlon-4 -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o libpostproc/postprocess.o libpostproc/postprocess.c
libpostproc/postprocess_template.c: In function `dering_MMX2':
libpostproc/postprocess_template.c:1186: can't find a register in class `GENERAL_REGS' while reloading `asm'
make[1]: *** [libpostproc/postprocess.o] Error 1
make[1]: Leaving directory `/home/mjh/Downloads/MPlayer-1.0pre7try2/libavcodec'
make: *** [libavcodec/libavcodec.a] Error 2


If I (try to) disable the MMX instructions, I get further, but fail at:

gcc32 -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -m32 -march=athlon-4 -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -o imdct.o imdct.c
In file included from imdct.c:761:
imdct_3dnow.h: In function `fft_asmb_3dnow':
imdct_3dnow.h:241: can't find a register in class `GENERAL_REGS' while reloading `asm'
make[1]: *** [imdct.o] Error 1
make[1]: Leaving directory `/home/mjh/Downloads/MPlayer-1.0pre7try2/liba52'
make: *** [liba52/liba52.a] Error 2


Even the full house (build me a slow one!) configure of

CFLAGS="-m32 -march=athlon-4" ./configure --cc=gcc32 --disable-fastmemcpy --disable-mmx --disable-mmx2 --disable-3dnow --disable-3dnowex

Does not get me past that point.

I can turn off most (read pretty much all) of the video support with:

CFLAGS="-m32 -march=athlon-4" ./configure --cc=gcc32 --disable-fastmemcpy --disable-mmx --disable-mmx2 --disable-3dnow --disable-3dnowex --disable-runtime-cpudetection --disable-liba52 --disable-dga --disable-xv --disable-vidix

(!!)

and produce something called mplayer, but it, well, doesn't do much

Any ideas?
 
Old 01-18-2006, 10:47 AM   #14
mwales
LQ Newbie
 
Registered: Jan 2005
Location: Grant, FL
Distribution: Mandrake 10 and FC4-64
Posts: 19

Rep: Reputation: 0
I have been able to compile both a 64 and 32 bit version of MPlayer on FC4-64. Here are some notes I jotted down when I was complete:

Quote:
MPlayer
-A little tricky to install.
-Lame MP3 issues for mencoder. Had to specifically tell lame to compile using /usr/lib64, which then caused it to put the lame libraries for 64-bit in that same directory. Mplayer would then recognize lame was in
the system.
- The version of GCC that comes with Fedora Mplayer doesn't like, so I have to use the -cc=gcc32 compiler option. Not too big of a deal. This was the same in both 64 and 32 bit versions.
- Has trouble finding the X11 libs. Have to tell it with-x11libdir=/usr/X11R6/lib64 as a configure option for it to compile the GUI.
- Entire 64-bit ./configure string is as follows (I don't know if the codec directory specification was necessary): ./configure --enable-gui --cc=gcc32 --with-x11libdir=/usr/X11R6/lib64 --with-codecsdir=/usr/local/lib/codecs/
- Finally got the 32-bit version to compile, with the latest mplayer source: ./configure --enable-gui --target=athlon_xp --cc="gcc32 -m32"
--as="as --32" --with-extralibdir=/usr/lib
I wasn't able to get 32-bit MPlayer to compile with MPlayer v1.0pre7 source, but later I saw they release MPlayer v1.0pre7try2 source and that one worked for me. I was able to compile both 64 and 32 bit versions, but I don't have both at the same time (I pretty much use 32bit only since the codecs are 32bit)

Good luck, hope this helps you.
 
Old 01-18-2006, 01:02 PM   #15
elsabio
LQ Newbie
 
Registered: Mar 2005
Location: england
Distribution: handbuilt (reliable), FC3 (flakey as a piecrust)
Posts: 9

Rep: Reputation: 0
That gets pretty close: Thanks. However, I am going to have to (forcibly) install additional 32 bit versions of libgtk+ and no doubt all the dependents it complained about (libz, libpng, libcdda_*, libnsl (hmm...), libsmbclient, ...).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer fails on FC4 x86_64 hedgert Linux - Software 5 12-09-2005 02:31 PM
Replace 64bit X with 32bit X on FC4 x86_64 rosholm Fedora 1 10-20-2005 08:01 PM
Flash on Linux X86_64 (fc4) itz2000 Linux - Software 4 09-24-2005 09:12 AM
mplayer doesnt install on my fc4 crimsonflame123 Linux - Software 10 09-18-2005 01:32 AM
Gdesklets and libgtop and FC4 x86_64 pafinator11 Linux - Software 1 08-15-2005 05:01 PM


All times are GMT -5. The time now is 03:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration