LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mplayer fullscreen problem (http://www.linuxquestions.org/questions/linux-software-2/mplayer-fullscreen-problem-272185/)

GTBlackwell 12-30-2004 11:50 PM

Mplayer fullscreen problem
 
I've run Mplayer on previous Linux installations but never had this problem. When I click the fullscreen button, the image rescales to the size of my screen, but remains confined to the window, allowing me to see only a small portion of the image. It kind of works if I maximize the screen, but the task- and title-bar remain. Any ideas how to fix the problem?

cjcox 12-31-2004 12:41 AM

Try a different video driver (-vo option).

Do mplayer -vo help for a list.

GTBlackwell 12-31-2004 01:16 AM

I tried all the video codecs that are available on my installation (I have Suse 9.0, btw), but none of them worked any better. Most in fact, were worse, either in video quality, brightness, color, something. And none worked in full screen. I'm beginning to wonder if it's some sort of priority problem, though I doubt it.

cjcox 12-31-2004 01:59 AM

Which video card do you have? .. and what X driver are you using with the card?

GTBlackwell 12-31-2004 02:30 AM

My card is an ATI radeon 9600 with 128MB of RAM (though Suse's using the drivers for the 9000, since that seems to be the only one that works) and I think the driver Mplayer uses is called X11/Xv. There are several others listed in Mplayer's 'Properties' dialog, but, as I said, this one works best out of those available.

cjcox 12-31-2004 10:15 PM

Well.. it does matter.. in mplayer

xv takes advantage of accelerated video scaling on the card. As with OpenGL, if this feature works well, it can map only one physical display device (usually).

x11 is just a plain ole x11 driver (useful when you have multiple active devices showing the same screen).

I'm going to guess that the 9600 could be the problem. You may want to try the ATI proprietary drivers and see if that clears things up. The bad news is that the ATI drivers may not work at all with the new xorg version of X. But I can't say anything for sure on that.

If you're serious about using a good card with Linux, Nvidia is the way to go.

GTBlackwell 01-02-2005 12:03 PM

I've installed the ATI drivers for my card. Everything seemed to install fine. I was asked to go to /lib/modules/fglrx/build_mod and run make.sh then switch to /lib/modules/fglrx and run make_install.sh. So I did that, ran fglrxconfig, and everything seemed fine. I restarted X and ran fglrxinfo in the terminal and got:

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

so it looks like it's working, but any programs requiring openGL still tell me no 3D accelerator is installed. Plus, I'm still having the same MPlayer problem.

I tried running fglrxinfo as root from a terminal window and got:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display :0

So I have no clue why the driver isn't working (or maybe it is and Suse doesn't know? That seems unlikely) and I still am having this MPlayer problem, which is happening with both MPlayer and gMPlayer.

cjcox 01-02-2005 03:34 PM

Well... I think we need someone with that card to post. I stopped using ATI quite a while ago (probably will never go back).

Don't know what to suggest.

GTBlackwell 01-02-2005 09:07 PM

The ironic part is that just a bit ago I had an nVidia card and sold it to my father. Oh well. Guess it gives me something to save for.

cjcox 01-02-2005 11:00 PM

Yep... maybe ATI will get their act together someday (but I've said that many a time before... I'm tired of dealing with them).

SlackerLX 01-02-2005 11:30 PM

Use XV driver

cjcox 01-03-2005 12:34 AM

xv is an accelerated (video scaling) video mode.

GTBlackwell 01-03-2005 11:30 AM

I've been using the xv driver. As I said, it's the one that works the best, but still won't let me use fullscreen mode.

snmraptorguy 01-13-2005 06:44 PM

I had the same problem on my machine. Just pass it the -zoom option:

$ mplayer -zoom somefile.avi

Then you can press the [F] button to fullscreen and the window should also fullscreen.


All times are GMT -5. The time now is 10:45 PM.