LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-25-2003, 11:08 AM   #1
Stanley56
Member
 
Registered: May 2003
Location: Belgium
Distribution: Gentoo, Debian
Posts: 44

Rep: Reputation: 15
Question mplayer -fs -> bottom border still shows desktop


I've installed Gentoo 1.4.20-r8 on my Athlon XP and I think its great. One of the best distributions I've ever seen.
I've installed mplayer with emerge but when i try playing a movie with "mplayer movie -fs" it does not spread across my entire desktop. The entire screen is as it should be except for a quarter of the bottom. There I just see my desktop. There's even a piece cut of of my movie. When I play a movie and press the f-key to spread it across the screen then everything is just fine.

It's not really a problem, but its irritating.

Does anyone know how to solve this?

P.S.: Sorry for my bad English. I'm not that good at it.

Last edited by Stanley56; 11-25-2003 at 11:10 AM.
 
Old 11-25-2003, 12:31 PM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
If you want fullscreen to be your default you can put it in your ~/.mplayer/config. But that doesn't explain the strange behavior and might not be what you want.

Did you try these 2 options, see manpage for better readability:

-fstype <type1,type2,...>
Specify a priority list of fullscreen layer setting modes to be used. The
available types are:

above
Use _NETWM_STATE_ABOVE hint if available.
below
Use _NETWM_STATE_BELOW hint if available.
fullscreen
Use _NETWM_STATE_FULLSCREEN hint if available.
layer
Use _WIN_LAYER hint with default layer.
layer=<0..15>
Use _WIN_LAYER hint with layer number.
netwm
Force NETWM style.
none Don't set fullscreen window layer.
stays_on_top
Use _NETWM_STATE_STAYS_ON_TOP hint if available.

It's possible to negate the modes by prefixing them with "-"
The default order is "layer,stays_on_top,above,fullscreen". It will be used as a
fallback in case of specifying incorrect or unsupported modes.
OpenBox 1.x users have to use -fstype -fullscreen to achieve working fs switching.
If you experience problems with fullscreen window being covered by other windows try
using a different order.

NOTE:
See -fstype help for a full list of available modes.


-fsmode-dontuse <0-31> (OBSOLETE) (use -fs option)
Try this option if you still experience fullscreen problems.

****end quote manpage****

The first one might help, the second one........ 'Dontuse and obsolete in the same sentence'. I tried them, it didn't harm my hardware :-)

If your problem still excists after the above, you can try to increase the output that mplayer shows.

some extra info: mplayer -fs -v <name_movie>
more extra info: mplayer -fs -v -v <name_movie>
all info: mplayer -fs -v -v <name_movie>
 
Old 11-26-2003, 06:10 AM   #3
Stanley56
Member
 
Registered: May 2003
Location: Belgium
Distribution: Gentoo, Debian
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks for your reply druuna.

Changing the order of "layer,stays_on_top,above,fullscreen" solved the problem of the missing part of the screen, but the movie isn't on top.
Could it be because my wm (gnome 2.4.0) does not support the "STAYS_ON_TOP state"?

From the output op mplayer:
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
==========================================================================
 
Old 11-26-2003, 03:56 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
I don't use gnome (xfce is my poison), so I cannot answer that question. Maybe there's a gnome specific forum, or the possibility to ask questions on the homepage af the gnome project.

Hope they can help.
 
Old 11-29-2003, 02:36 PM   #5
Stanley56
Member
 
Registered: May 2003
Location: Belgium
Distribution: Gentoo, Debian
Posts: 44

Original Poster
Rep: Reputation: 15
The movie is fullscreen as it should be, but the gnome panels are still above it until I click the on movie. I am having the impression it not a problem with stay_on_top.
I tried all combinations of fstype but it din't solve the problem.
The strange thing is that if a combination has the problem of my original problem the panels aren't on top. Only if it solves the original problem the problem with the panels occurs.

btw: I found that in if fullscreen in "layer,above,stays_on_top,above,fullscreen" does not stand behind above it solves the problem.

I only really like my linux when it's perfectly configured. But that can take some time and patience.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE: Disable Desktop switch when Mouse on border Snyke Linux - Software 2 09-13-2005 07:52 AM
my mplayer shows everythin upside down.help meout amolgupta Linux - Software 1 07-28-2005 07:33 AM
Gnome(nautilus) border when moving desktop file bumpert Linux - Software 1 06-25-2005 04:32 PM
desktop shows on TV but movie shows black screen litrelord Mandriva 6 07-05-2004 05:10 AM
mplayer shows half screen for avi's gervin Linux - Newbie 8 03-14-2004 10:30 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration