LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-20-2004, 05:05 PM   #1
munna_502
LQ Newbie
 
Registered: Aug 2003
Location: Pakistan
Posts: 29

Rep: Reputation: 15
Red face MPlayer Error


I am installing MPlayer by this command

rpm -Uvh mplayer-common-1.0pre3-1.i386.rpm mplayer-gui-1.0pre3-1.i386.rpm lame-3.93.1-1.i386.rpm mplayer-skin-default-1.0-2.noarch.rpm

but it give me a error like this

warning: mplayer-common-1.0pre3-1.i386.rpm: V3 DSA signature: NOKEY, key ID 75aa026a
error: Failed dependencies:
libmp3lame.so.0 is needed by mplayer-gui-1.0pre3-1
lame-libs = 3.93.1 is needed by lame-3.93.1-1

Plz help me in this error .how can i solve it.i am new in linux and trying to say good bye to Microsoft
 
Old 02-20-2004, 05:57 PM   #2
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
Try "rpm -Uvh --nodeps files.rpm" You may have a bad package but it could be an endless enigma rpms are famous for.
 
Old 02-20-2004, 06:10 PM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Get the Lame package from freshrpms.net and you should be able to install it OK.

Håkan
 
Old 02-20-2004, 06:27 PM   #4
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Rep: Reputation: 0
Check out the thread 'mplayer is not installing on Red Hat Linux 9.0' under the same board as this.
I was havin similar problems and apt fixed it for me. Just check out the thread.
 
Old 02-20-2004, 06:40 PM   #5
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I was so frustratedm of rpm dependencies, I tried to compile mplayer from source. It worked beautifuly, it was also very satisfing to do it my self(my first source install).
 
Old 02-20-2004, 06:50 PM   #6
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Rep: Reputation: 0
RPM vs. source :p

I only had the bad share of RPM dependency issues myself shanenin. I am also a beginner with Linux and when I tried installing from source I got an error saying that I do not have the right gcc package installed (whatever that is) and that mplayer does not support my version (2.96). So there went installing from source . Instead I installed apt hit the command "apt-get install mplayer" and it did everything. Not as satisfying but still great to have it working.
 
Old 02-20-2004, 07:25 PM   #7
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
in regards to having the right gcc package, you need to install your developmental packages. They are on you install cds(I am guessing you have redhat). Goto add/remove programs(it will prompt you to insert one of your disks) and install all of your developmental packages. These packages are required to compile and install anything from source. If you plan on sticking with linux, you should get used to compiling programs. Goodluck with what your endevers :-)
 
Old 02-20-2004, 07:28 PM   #8
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I forgot to say one thing. I am glad you got your problem solved.
 
Old 02-21-2004, 05:08 AM   #9
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Rep: Reputation: 0
Reply

Thanks for the ideas and wishes. I'm starting to like it so I'll stick around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while parsing chunk header. Mplayer error only under Slack vdemuth Linux - Software 5 02-19-2007 11:09 AM
MPlayer -vo error hlinux Fedora 5 07-22-2006 01:11 PM
MPlayer error aw76 Linux - Software 1 11-30-2005 11:17 AM
Error in mplayer....... avols143 Linux - Software 2 02-17-2004 10:08 AM
mplayer error dibblethewrecke Linux - Software 3 12-01-2003 04:00 PM


All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration