LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-01-2003, 02:07 PM   #1
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Rep: Reputation: 30
mplayer error


i just tried to run mplayer for the first time and got the follwoing output and error:

root@localhost MPlayer-0.92]# mplayer -dvd 2
MPlayer 0.92-3.2.2 (C) 2000-2003 MPlayer Team
CPU: Intel Celeron A Mendocino/Pentium II Dixon (Family: 6, Stepping: 10)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing DVD title 2
Reading disc structure, please wait...
There are 9 titles on this DVD.
There are 7 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25.00 fps 8400.0 kbps (1050.0 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
No accelerated IMDCT transform found
AC3: 5.1 (3f+2r+lfe) 48000 Hz 448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMX for IDCT transform
libmpeg2: Using MMX for motion compensation
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
X11 error: BadAlloc (insufficient resources for operation) 0.0% 1 0 0%


MPlayer interrupted by signal 6 in module: flip_page
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
and follow the instructions there. We can't and won't help unless you provide
this information when reporting a possible bug.
Xlib: unexpected async reply (sequence 0x57)!


What have i done wrong? Please don't shout at me, I'm a newbie.
 
Old 12-01-2003, 02:12 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Quote:
The selected video_out device is incompatible with this codec.
VDecoder init failed
Select another video output (xv or something) in the Mplayer config (either your own config file or in the graphical user interface) and try again.

Håkan
 
Old 12-01-2003, 04:53 PM   #3
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
i tried to reinstall mplayer with the gui enabled but failed because i don't have gtk 1.2 although i am sure i do.

1st - how can i check i have gtk 1.2?
2nd - why won't it work if i have

having tried to reinstall and failed i tried to replicate my previous error and got this:

libdvdread: Can't open file VIDEO_TS.IFO.
Can't open VMG info!

am starting to feel it all going wrong!
 
Old 12-01-2003, 05:00 PM   #4
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
i am so stupid. i swapped my dvd out for a source disk...i'm ashamed....

However!

i still need advice on my gui install problem as the command line confuses me a bit.

as far as playback is concerned

i've tried lots of -vo -ao combinations and the performance is still pretty poor. I tried -framedrop and that worked pretty well

the best combination i have found is:

mplayer -vo x11 -ao oss -framedrop

i read the readme and it says using x11 is bad but i can't get xv to work at all. I have a neomagic card and i have to make this change:

Option "OverlayMem" "829440"

in XF86Config but i am not sure of how to do this.

>>>>>(i started a new thread on this here http://www.linuxquestions.org/questi...hreadid=121936)<<<<<

Last edited by dibblethewrecke; 12-02-2003 at 09:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while parsing chunk header. Mplayer error only under Slack vdemuth Linux - Software 5 02-19-2007 12:09 PM
MPlayer -vo error hlinux Fedora 5 07-22-2006 02:11 PM
MPlayer error aw76 Linux - Software 1 11-30-2005 12:17 PM
Error in mplayer....... avols143 Linux - Software 2 02-17-2004 11:08 AM
MPlayer Error! TheShemeta Linux - Software 1 11-04-2003 09:42 AM


All times are GMT -5. The time now is 01:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration