LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-19-2006, 03:59 AM   #1
toffi22
Member
 
Registered: Sep 2004
Location: Bonn, Germany
Posts: 32

Rep: Reputation: 15
Unhappy Mplayer /dev/dvd but no dvd://


Hi!

I installed MPlayer yesterday and after some trying, it played the VIDEO_TS/*.vob-files on my dvd (when it was mounted) with sound. If I call mplayer /dev/dvd (when the drive is not mounted), it starts playing but there's no sound and if I try to play dvd://<track name> I get the following output:

mplayer dvd://5
MPlayer 1.0pre7try2-4.0.2 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium M Banias (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


85 audio & 196 video codecs
Failed to open /dev/rtc: No such file or directory (it should be readable by the user.)
Playing dvd://5.
Reading disc structure, please wait...
There are 10 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 8000.0 kbps (1000.0 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo) 48000 Hz 224.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1400x1050 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
AF_pre: 48000Hz/2ch/s16le
AO: [oss] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
A: 0.4 V: 0.0 A-V: 0.409 ct: 0.004 1/ 1 ??% ??% ??,?% 0 0

Exiting... (End of file)


From those lines, I can't figure out why dvd:// is not working..

Would you please help me??

- Christoph
 
Old 01-19-2006, 05:04 AM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Probably its a menu. MPlayer does not play menus. You have to use xine or video lan client for that. Usually title 1 is the movie. Check the volumes using alsamixer. If you did not run alsactl store before shutting down, your sound will be muted.

You may want to include -vf scale=-1:-1,yuy2 to increase video performance in mplayer after you have it working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD Player Problem in fedora /dev/dvd not found sxa Linux - Hardware 9 08-23-2006 08:17 PM
Sony DVD DDU1612. /dev/dvd no such file lamedavis Linux - Hardware 2 03-30-2004 06:06 PM
symbolic linking dvd-rom to /dev/dvd ? Falcon006 Linux - Newbie 3 03-20-2004 12:57 AM
Coudn't open DVD device: /dev/dvd eboggess Linux - Laptop and Netbook 3 10-18-2003 06:02 PM
mplayer: cant access /dev/dvd bulliver Linux - Software 9 08-26-2003 05:58 AM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration