LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-12-2005, 03:33 PM   #1
laurentwahl
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 141

Rep: Reputation: 15
mplayer: Couldn't find matching filter/ao format!


Hello
I have installed Mplayer and the Programm works with avi files and with most of dvd's.

But with some dvd's, I only hear a grating noise. He writes:
Quote:
Checking audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
AF_pre: 48000Hz/2ch/ac3
[AO OSS] Can't set audio device /dev/dsp to ac3 output, trying s16le...
AO: [oss] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/s16le...
[format] Sample format big-endian AC3 not yet supported
[libaf] Reinitialization did not work, audio filter 'format' returned error code -2
Couldn't find matching filter/ao format!
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12
A: 0.7 V: 0.7 A-V: 0.003 ct: 0.031 16/ 13 ??% ??% ??,?% 1 0
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.No bind found for key MOUSE_BTN0
I can see the pictures, but the sound doesn't work. Can anybody help me?
 
Old 07-12-2005, 03:48 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
ac3 format shouldn't be a problem with a default mplayer RPM... don't think there are any copyright issues there... one thing is to use alsa output, not oss (-ao alsa) and see if that improves it, other than that i'd suggest a REAL source compile so you know that it's not down to fedora taking out the useful bits and replacing them with twigs and gum.
 
Old 07-12-2005, 04:05 PM   #3
laurentwahl
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 141

Original Poster
Rep: Reputation: 15
if I use the alsa driver with
mplayer -ao alsa dvd://
he says
Quote:
Checking audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
AF_pre: 48000Hz/2ch/ac3
alsa-init: 1 soundcard found, using: iec958:{CARD 0 AES0 0x02 AES1 0x82 AES2 0x00 AES3 0x02}
ALSA lib setup.c:547add_elem) Cannot obtain info for CTL elem (MIXER,'IEC958 Playback Default',0,0,0): No such file or directory
alsa-init: playback open error: No such file or directory
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12
V: 0.7 16/ 13 ??% ??% ??,?% 0 0
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
Then I didn't hear anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Find/grep command to find matching files, print filename, then print matching content stefanlasiewski Programming 8 12-18-2013 05:36 PM
error when rebooting could'nt find matching filesystem: label=/home bigdawg9950 Linux - Newbie 2 08-30-2004 02:03 AM
Couldn't find matching filesystem ashesh Linux - General 2 05-23-2004 01:18 AM
ut2003--- couldn't set video mode:couldn't find matching GLX visual <h1>tux</h1> Linux - Newbie 1 08-22-2003 07:17 PM
Couldn't find matching file system: LABEL=/user1 kausik Linux - General 4 05-20-2002 06:00 AM


All times are GMT -5. The time now is 06:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration