LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-26-2005, 08:56 AM   #1
jrmontg
Member
 
Registered: Nov 2004
Posts: 58

Rep: Reputation: 15
Mplayer cannot play wmv files


I have installed Mplayer but I am having issues playing wmv files.

I get this: Error opening/initializing the selected video_out (-vo) device.

I was thinking it could be codecs so I downloaded from http://www2.mplayerhq.hu/homepage/design7/codecs.html and installed it in multiple places
like /usr/lib/win32, usr/local/lib/win32 and usr/local/lib/codecs

I am still getting the same error.

Please advise, thanks
 
Old 01-26-2005, 09:06 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
if you install those codecs then you ned to recompile mplayer afterwards. once you've done the ./configure, you will get a summary of how it will be built, including wether win32 codecs will be found.
 
Old 01-26-2005, 09:18 AM   #3
jrmontg
Member
 
Registered: Nov 2004
Posts: 58

Original Poster
Rep: Reputation: 15
Oh, great.

I used Synaptic to install Mplayer. I tried unistalling and resinstalling and that didn't work.
 
Old 01-26-2005, 09:20 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
ahh well if it's through synaptic, then the win32 codecs should also have been installed through that means as an implicit dependency... maybe that mplayer built is fixed to not use them... the joys of not compiling from source....
 
Old 01-26-2005, 09:44 AM   #5
jrmontg
Member
 
Registered: Nov 2004
Posts: 58

Original Poster
Rep: Reputation: 15
That got me thinking. I tried this. I searched for a video clip and streamed it from firefox using mplayer and it worked. But is I download that same clip I get that error trying to play it with Mplayer. Wierd
 
Old 01-27-2005, 05:58 AM   #6
dth1
Member
 
Registered: Oct 2004
Location: Stoney Stanton - England
Distribution: openSuse 13.1 64 bit
Posts: 324

Rep: Reputation: 32
is your system a 64 bit AMD processor?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make xine or mplayer play .wmv files kkempter Linux - Software 22 07-25-2006 11:03 AM
Cant Play wmv files on mplayer or xine irish rebel Linux - Software 1 10-22-2004 10:32 PM
Cannot play wma or wmv files in mplayer Fear58 Linux - Software 4 07-31-2004 03:59 AM
mplayer cannot play audio (asf) and wmv in firefox caneforever97 Linux - Newbie 8 04-23-2004 11:45 AM
Mplayer unable to play 'wmv' format harsha_vardhan Linux - Software 1 02-02-2004 01:30 PM


All times are GMT -5. The time now is 11:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration