LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-05-2004, 09:39 AM   #1
jojoii
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
mplayer: Can't open /dev/fb0: Permission denied


hi;
i instaled debian testing, compiled mplayer and tryed to watch some movie:
this is the result:

jojoii@krutihome:~$ mplayer mvn-re2ts01.bin
MPlayer 1.0pre5-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2009 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/jojoii/.mplayer/config
Reading /home/jojoii/.mplayer/codecs.conf: Can't open '/home/jojoii/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/jojoii/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Using usleep() timing
Can't open input config file /home/jojoii/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing mvn-re2ts01.bin.
MPEG-PS file format detected.
VIDEO: MPEG2 480x576 (aspect 2) 25.000 fps 2521.2 kbps (315.2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Can't open /dev/fb0: Permission denied
[fbdev2] Can't open /dev/fb0: Permission denied
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 480 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
audio_setup: Can't open audio device /dev/dsp: Permission denied
AO: [null] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 480 x 576 (preferred csp: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler: using unscaled Planar YV12 -> BGR 24-bit special converter
VO: [png] 480x576 => 768x576 BGR 24-bit
PNG Warning: compression level set to 0, compression disabled!
PNG Info: Use the -z <n> switch to set compression level from 0 to 9.
PNG Info: (0 = no compression, 1 = fastest, lowest - 9 best, slowest compression)
A: 2.3 V: 1.6 A-V: 0.685 ct: 0.088 23/ 23 6% 161% 1.2% 17 0 0%

MPlayer interrupted by signal 2 in module: decode_video
jojoii@krutihome:~$



the movie seem to be runnig, so i thing it`s not the codecs problem, but there is no video output.
i tryed to change /dev/fb0 permissions, but it doesn`t work.

can anybody help me?
thanx
 
Old 09-21-2008, 02:54 PM   #2
pdallas
LQ Newbie
 
Registered: Dec 2007
Posts: 8

Rep: Reputation: 0
Smile This may help

Well, this is rather a complicated issue. You can find a lot of info on http://bbs.archlinux.org/viewtopic.php?id=36832; maybe you already have...
The mplayer documentation generally seems to favour the xv video output option; I don't blame them, it is rather stable. For it to work, xv must be installed *before* compiling mplayer. What I have done (though some of it may be superfluous) is:
- The X11 screen was set using sax2, for 1024x768, 16.7Million colours.
- I set up the frame buffer for 1024x768, 16.7Million colours. This is actually done by altering the boot manager settings (in my case, grub). I used boot option vga=0x318; other options (from the web page mentioned above) are:
# FRAMEBUFFER RESOLUTION SETTINGS
# +-------------------------------------------------+
# | 640x480 800x600 1024x768 1280x1024
# ----+--------------------------------------------
# 256 | 0x301=769 0x303=771 0x305=773 0x307=775
# 32K | 0x310=784 0x313=787 0x316=790 0x319=793
# 64K | 0x311=785 0x314=788 0x317=791 0x31A=794
# 16M | 0x312=786 0x315=789 0x318=792 0x31B=795
# +-------------------------------------------------+
- I installed the following packages:
xorg-x11-Xvnc
xorg-x11-libXv
xorg-x11-server-extra
xvattr
xvkbd
(this was done with Yast2 in Suse Linux 11.0).
- I then compiled / made MPlayer-1.0rc2.
This then worked fine! In principle, one needs to type
mplayer -vo xv [file],
but I have found that mplayer actually finds xv and automatically selects it, at least in my case.
 
Old 09-21-2008, 05:56 PM   #3
Renan_S2
Member
 
Registered: Jul 2007
Location: Santa Maria, Brazil
Distribution: Arch Linux
Posts: 66

Rep: Reputation: 16
If you have framebuffer working, try adding yourself to the 'video' group (or whatever the group that /dev/fb0 is in).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/null: Permission denied phoenix7 Linux - Distributions 1 10-01-2005 06:31 PM
Permission denied on /dev/hda1 after chrooting pwaring Linux - General 11 09-05-2005 03:53 AM
ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied qazwsx27 Fedora 3 06-14-2005 02:09 PM
/dev/null: Permission denied LavaDevil94 Linux - Software 2 09-14-2004 11:44 PM
/dev/dsp: Permission denied jtX Slackware 1 02-06-2004 05:39 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration