LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-25-2007, 04:02 PM   #1
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Rep: Reputation: 33
MPlayer -- Audio-Video desynchronized in FLV files


Many FLV files when played with MPlayer do not have their audio and video synchronized. For example, the person's lips move and then their voice is heard. You cannot jump to any particular point in the video by pressing the arrow keys or clicking at that particular point in the playbar.

If you press the forward ( --> ) key when the sound is desynchronized, the audio and video will synchronize temporarily (for a few seconds) and then the lag appears once more, instead of moving forward in the video for 10 seconds. If you play the video from the command line, you can see that the "A-V" tag is more than one, and keeps increasing or decreasing slowly.

Is this a bug in Mplayer or a particular codec? I faced the same problem in RH 9. There is nothing wrong with the files as they play perfectly well when incorporated in a swf file or played with the stand alone Windows FLVPlayer.

What do I do?

Last edited by gregorian; 04-25-2007 at 04:03 PM.
 
Old 04-25-2007, 09:31 PM   #2
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Have you tried different outputs for sound and video?
mplayer -vo help
mplayer -ao help
 
Old 04-25-2007, 11:26 PM   #3
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
I executed the commands, but is this really problem related to the output drivers? Some FLV files play properly while some don't, yet both of them work properly when used in Windows FLVPlayer or when they're incorporated in swf files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
copy-mode extract of audio from youtube flv video moob8 Linux - Desktop 18 10-05-2013 08:44 AM
Inability of Mplayer to play flv files gregorian Linux - Software 5 01-18-2007 01:53 AM
No Video/Audio using MPlayer vaneeri Red Hat 7 10-15-2004 12:35 AM
only audio but no video when playing .mpeg files with MPlayer-0.90 koodoo Linux - Newbie 3 10-01-2004 03:43 AM
MPlayer video/audio drivers tipaul Slackware 4 09-04-2003 11:47 AM


All times are GMT -5. The time now is 10:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration