LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-02-2003, 02:48 PM   #1
garorag
LQ Newbie
 
Registered: Sep 2001
Location: india
Distribution: pcq linux 7.1
Posts: 17

Rep: Reputation: 0
Angry mplayer


i downloaded following mplayer components
1.mplayer-common-0.90-1.athlon.rpm
2.mplayer-0.90-1.athlon.rpm
3.mencoder-0.90-1.athlon.rpm
4.mplayer-gui-0.90-1.athlon.rpm
5.mplayer-skin-default-1.0-2.noarch.rpm

(my system is athlon thunderbird)

i install all these packages

but when i write command in shell
#mplayer

MPlayer 0.90-RPM-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon TB Thunderbird (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
MPlayer was compiled WITHOUT GUI support.
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
Usage: mplayer [options] [url|path/]filename



-------------------------------------------------
following is my mplayer.conf

##
## MPlayer config file
##
## This file can be copied to /usr/local/etc/mplayer.conf and/or ~/.mplayer/config .
## If both exist, the ~/.mplayer/config's settings override the
## /usr/local/etc/mplayer.conf ones. And, of course command line overrides all.
## The options are the same as in the command line, but they can be specified
## more flexibly here. See below.
##

vo=xv # To specify default video driver (see -vo help for
# list)

# ao=oss # To specify default audio driver (see -ao help for
# list)

# fs=yes # Enlarges movie window to your desktop's size.
# Used by drivers: all

# vm=no # Tries to change to a different videomode
# Used by drivers: dga2, x11, sdl

# bpp=0 # Force changing display depth.
# Valid settings are: 0, 15, 16, 24, 32
# may need 'vm=yes' too.
# Used by drivers: fbdev, dga2, svga, vesa

# zoom=no # Enable software scaling (powerful CPU needed)
# Used by drivers: svga, x11, vesa

# double=yes # use double-buffering (recommended for xv with
# SUB/OSD usage)

# monitoraspect=4:3 # standard monitor size, with square pixels
# monitoraspect=16:9 # use this for widescreen monitor! non-square pixels

##
## Use GUI mode by default
##

gui = yes

##
## Specify your preferred default skin here
## (skins are searched in /usr/local/share/mplayer/Skin/yourskin
## and ~/.mplayer/Skin/yourskin)
##

skin = /usr/share/mplayer/Skin/MidnightLove

##
## Multiple languages are available
##
## Hungarian igen nem
## English yes no
## German ja nein
## Spanish si no
## Binary 1 0
##
## You can also use spaces and/or tabs.
##

# sound = 1
# nosound = nein
# mixer = /dev/mixer

##
## resample the fonts' alphamap
## 0 plain white fonts
## 0.75 very narrow black outline (default)
## 1 narrow black outline
## 10 bold black outline
##

# ffactor = 0.75

##
## FBdev driver:

# fb = /dev/fb0 # framebuffer device to use
# fbmode = 640x480-120 # use this mode (read from fb.modes!)
# fbmodeconfig = /etc/fb.modes # the fb.modes file

## VESA and FBdev driver: specify your monitor's timings
##
## (see for example /etc/X11/XF86Config for timings!)
## ** CAUTION! IF YOUR DISPLAY DOESN'T SUPPORT AUTOMATICALLY TURNING OFF WHEN
## OVERDRIVED (AND EVEN IF IT DOES), THIS MAY CAUSE DAMAGE TO YOUR DISPLAY!
## WE AREN'T RESPONSIBLE, IT'S YOUR DECISION! **
##
## k, K : means multiply by 1000
## m, M : means multiply by 1.000.000
##
# monitor_hfreq = 31.5k-50k,70k # horizontal frequency range
# monitor_vfreq = 50-90 # vertical frequency range
# monitor_dotclock = 30M-300M # dotclock (or pixelclock) range

##
## SDL driver
##

# vo = sdl:aalib # use SDL video driver by default
# use "vo = sdl:aalib" or "vo sdl:dga" and so on,
# for specifying SDL subdrivers
# ao = sdl:esd # use SDL audio driver by default
# use "ao = sdl:esd" to use SDL's ESD driver
# noxv = no # whether to use XVideo hardware acceleration or not
# forcexv = yes # force XVideo even if not detected


##
## Other (preferred to be default from configfile) switches
##

framedrop = yes # drop frames, when not in sync (slow CPU, videocard,
# etc)

cache = 8192 # use 8Mb input cache by default

# slang = en # DVD : display english subtitles if available
# alang = en # DVD : play english audio tracks if available


## This is the correct way to use "subconfig" type options in the
## configuration file. In the command line you use :
## -aop list=resample:fout=44100 , but here it is :
# aop=list=resample:fout=44100

##
## You can also include other configfiles
## Specify full path!
##
## Delete this default
##




please tell me how it works
 
Old 08-02-2003, 02:50 PM   #2
jvds
Member
 
Registered: Jul 2003
Posts: 88

Rep: Reputation: 15
Try mplayer filename.mpg as you are not specifying the file to play

Rus
 
Old 08-02-2003, 03:16 PM   #3
garorag
LQ Newbie
 
Registered: Sep 2001
Location: india
Distribution: pcq linux 7.1
Posts: 17

Original Poster
Rep: Reputation: 0
mplayer

it is playing the movie but i want to use graphic mode(skin)

and when i use command
# gmplayer

MPlayer 0.90-RPM-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon TB Thunderbird (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Input config file /root/.mplayer/input.conf parsed : 52 binds
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).



please help me
 
Old 08-02-2003, 03:25 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
"Skin not found ( default )."

You've to install skins...

http://www.mplayerhq.hu/DOCS/#gui
 
Old 08-02-2003, 03:30 PM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Oh yeah, one more tip

# gmplayer

You are running programs as root? You know it's not recommended don't you
 
Old 08-02-2003, 03:42 PM   #6
garorag
LQ Newbie
 
Registered: Sep 2001
Location: india
Distribution: pcq linux 7.1
Posts: 17

Original Poster
Rep: Reputation: 0
i have already install two skins file:/usr/share/mplayer/Skin

1.Default
2.MidnightLove
 
Old 08-02-2003, 03:55 PM   #7
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I see. Installing from rpm's . Well, I did it from source, and, it's not the file "default" that you must have at /usr/share/mplayer/Skin, it's actually a directory called default with an skin inside (note, default lower case "d", not uppercase "D").
Try creating a folder at /usr/share/mplayer/Skin called default and put a skin in there.
If it still does not work, try creating a folder at /home/.mplayer/Skin/default

and place the default skin there . Hope this helps. I wish you good luck
 
Old 08-02-2003, 04:04 PM   #8
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Well, I think... here it reads:

"They should be extracted to the usual system-wide directory ($PREFIX/share/mplayer/Skin), or to $HOME/.mplayer/Skin. MPlayer by default looks in these directories for a directory named default, but you can use the -skin newskin option, or the skin=newskin config file directive to use the skin in */Skin/newskin directory."

They should really make a better documentation for mplayer...
 
Old 08-31-2003, 02:49 PM   #9
munna_502
LQ Newbie
 
Registered: Aug 2003
Location: Pakistan
Posts: 29

Rep: Reputation: 15
you have to download the mplayer from the site
Mplayer
there are three file you have to download

mplayer-common-0.90-1.i386.rpm

mplayer-gui-0.90-1.i386.rpm

mplayer-skin-default-1.0-2.noarch.rpm

when u have to down load these files then install them with this command

rpm -Uvh mplayer-common-0.90rc3-1.i386.rpm mplayer-gui-0.90rc3-1.i386.rpm mplayer-skin-default-1.6-3.noarch.rpm


this command must be in one line
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
using mplayer with .asx without -playlist? Would be useful for mplayer plug-in pierrethibault Linux - Software 1 02-18-2005 08:12 AM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 12:58 AM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 10:44 AM
More mplayer issues...no /.mplayer folder?! lt1derful Linux - Software 3 08-03-2003 09:09 PM
mplayer is cool ... mplayer plug-in is even cooler..! linuxlah Linux - General 4 07-16-2003 10:55 PM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration