LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-26-2003, 06:05 AM   #1
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Rep: Reputation: 15
mplayer


I brought from yhe net all pakage and install trhem .No conflict he said.But no working at least image..insted it tels me
==========================================================================
vo: X11 running at 1400x1050 with depth 24 and 32 bpp (":0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Couldn't find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
Sorry, selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMXEXT for IDCT transform
libmpeg2: Using MMXEXT for motion compensation
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
 
Old 01-26-2003, 06:09 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
what is wrong? there are *no* critical error messages in there.
 
Old 01-26-2003, 02:21 PM   #3
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
did your movies start?
 
Old 01-26-2003, 07:01 PM   #4
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15
Yes the moovie is starting,I can here the music but y can't see nothing....But the way the moovie is god(under wintrash can play it).I think is my radeon the problem..Cant install it al the way and I can't change refrash ider...I tried to instal xine...But i got stock at Opengl who normaly comes with the driver...Could it be this versionof RH(8)??Cause everithing was functioning in Mandrake 9....
 
Old 01-27-2003, 02:31 AM   #5
pagal
Member
 
Registered: Oct 2002
Distribution: Red Hat Phoebe!
Posts: 92

Rep: Reputation: 15
try using
mplayer -vo x11 moviepath/name
 
Old 01-27-2003, 03:47 AM   #6
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15
Yes pagal YES YES YES
Thanks your the best THanks a lot
I jut awake and try it works great
I am greatful for your advice.Once again this forum help me out.
How can I make him grafical with skin so that I can see all the posibilities ofert by this soft??Can I lisen radio from the net??like WMplayer9??
Thanks pagal and everybody...

Last edited by opo; 01-27-2003 at 03:51 AM.
 
Old 01-27-2003, 08:58 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you can load the gui with gmplayer, if it's already installed. but you'll get SO much more information in the manpage (man mplayer) gui's are overrated. you can listen to most radio streams, can take a little fiddling about with though.

btw X11 is a poor video output, if "xvinfo" reports that you DO have xv, you should use that instead, X11 will use considerably more CPU power
 
Old 01-27-2003, 07:29 PM   #8
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks again.Is ok but is not working with xv...
Another problem that i have with is that I can switch it to full screen but image is the same as 1X.What should I do??
Best Regards
 
Old 01-27-2003, 07:44 PM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Look into using the -zoom function, and also check out getting xv working.
 
Old 02-02-2003, 05:13 PM   #10
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15
how can i do xv working??how sould i do it??From time to time when i switch to full screen it schows me ....
MPlayer interrupted by signal 11 in module: key_events
[x11] NET style stay on top ( layer 1 ). Using state _NET_WM_STATE_FULLSCREEN.
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. For details, see DOCS/bugreports.html#crash.b.
[x11] NET style stay on top ( layer 1 ). Using state _NET_WM_STATE_FULLSCREEN.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
and follow the instructions there. We can't and won't help unless you provide
this information when reporting a possible bug.
 
Old 02-07-2003, 03:38 PM   #11
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15

[io@localhost io]$ xvinfo
X-Video Extension version 2.2
screen #0
Adaptor #0: "ATI Radeon Video Overlay"
number of ports: 1
port base: 55
operations supported: PutImage
supported visuals:
depth 24, visualID 0x23
depth 24, visualID 0x24
depth 24, visualID 0x25
depth 24, visualID 0x26
number of attributes: 4
"XV_COLORKEY" (range 0 to 16777215)
client settable attribute
client gettable attribute (current value is 0)
"XV_BRIGHTNESS" (range -64 to 63)
client settable attribute
client gettable attribute (current value is 0)
"XV_SATURATION" (range 0 to 31)
client settable attribute
client gettable attribute (current value is 16)
"XV_DOUBLE_BUFFER" (range 0 to 1)
client settable attribute
client gettable attribute (current value is 1)
maximum XvImage size: 2048 x 2048
Number of image formats: 4
id: 0x32595559 (YUY2)
guid: 59555932-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x59565955 (UYVY)
guid: 55595659-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x32315659 (YV12)
guid: 59563132-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
id: 0x30323449 (I420)
guid: 49343230-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)



but mlayer -vo Xv steel not working
What now??

Error opening/initializing the selected video_out (-vo) device.

Last edited by opo; 02-07-2003 at 03:41 PM.
 
Old 02-07-2003, 04:36 PM   #12
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
it's just "xv" not "Xv" if that's what you're typing. run mplayer -vo help for a list of outputs your mplayer has
 
Old 02-08-2003, 03:43 AM   #13
opo
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat 8.0
Posts: 24

Original Poster
Rep: Reputation: 15
the screen is black all the time
and this is what i see on the terminal
AF_pre: af format: 2 bps, 1 ch, 11025 hz, little endian signed int
AF_pre: 11025Hz 1ch Signed 16-bit (Little-Endian)
AO: [oss] 11025Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 11025Hz/1ch/16bit -> 11025Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 480 x 320 (preferred csp: Planar YVU9)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
VDec: using Planar YVU9 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: using unscaled Planar YVU9 -> Planar YV12 special converter
VO: [xv] 480x320 => 480x320 Planar YV12
warning: first frame is no keyframe
Broken pipe 19.8 A-V: 0.000 ct: -0.002 298/298 2% 3% 0.1% 1 0 77%
 
Old 02-08-2003, 03:49 AM   #14
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
looks like you've got a duff file going by the last two lines
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
using mplayer with .asx without -playlist? Would be useful for mplayer plug-in pierrethibault Linux - Software 1 02-18-2005 09:12 AM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 01:58 AM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 11:44 AM
More mplayer issues...no /.mplayer folder?! lt1derful Linux - Software 3 08-03-2003 10:09 PM
mplayer is cool ... mplayer plug-in is even cooler..! linuxlah Linux - General 4 07-16-2003 11:55 PM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration